0

I tried Pidgin on my Ubuntu 12.04 and it showed a very buggy behaviour. It could never connect to gtalk and even crashed sometimes in the process. So I decided to switch to Empathy. But it has its own problems. It connects to my gtalk and yahoo accounts, but there is another gtalk account which it can't connect to, and when I try to see what's wrong by going to Edit->Account, the Edit Account window shows for a second and then immediately disappears. I tried re-installing whole empathy package (and reboot a few times in the process), but it didn't work. Any idea what to do now?

0

Pidgin should be rock solid with GTalk - I've been using it on my Ubuntu 12.04 for about a year now, so I suspect either your system (how did you build/install Pidgin, do you have any unusual plug-ins enabled?), or a networking issue (do you have firewalls or proxies in place that would affect internet access?).

However, Google are also in the process of migrating GTalk accounts to Hangouts, so there might be some issues around that. Some stories report that they're dropping xmpp support entirely, but that would appear to be false - they're dropping xmpp "server" support, so clients will continue to work, but you won't be able to federate your own Jabber servers to Hangouts like you could in the past.

  • I had so optimistically installed skype plugins the first time I had installed pidgin. This time I just installed pidgin itself with no plugin. It worked fine for the first time, but one of my gtalk accounts didn't connect. After I changed some settings in accounts window and tried to reconnect, Pidgin stopped working completely. Killing the process (via ubuntu task manager) and restarting pidgin didn't help either. As for empathy, after rebooting, it let me open Edit->accounts and change some settings. But after connecting, it shows the same behavior again :( – user155878 May 28 '13 at 10:06
  • And I have none of these problems connecting to hangout from my android device... – user155878 May 28 '13 at 10:06
  • I have no idea what could cause this behaviour - sorry. I've just checked my Pidgin again and there's absolutely nothing interesting about my config. Start Pidgin, hit CTRL-A, Add account, Choose "Google Talk", enter username, password and you're done. – Scaine May 28 '13 at 10:58
  • It works now! But I still get occasional crashes...But it's tolerable now. Thanks for suggesting pidgin without plugins! – user155878 May 29 '13 at 17:18
  • You could maybe try launching pidgin from inside a terminal, so if it crashes, you might get some extra output which suggests what the problem is. Might be worth a shot. – Scaine May 29 '13 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.