So, my update to 13.04 didn't go very well. Due to the lack of a decent driver (Yes, i'm unlucky to have a legacy driver which doesn't play nice with the new Xorg.), I had to mess around with stuff to first troubleshoot and afterwards "fix" my system.

I've finally got unity back, but now CtrlAltarrow and CtrlAltShiftarrow don't work anymore. They are bound in "keyboard" > "shortcuts", but nothing happens when I try it. A strange thing is that other keyboard shortcuts, like ctrlaltt to show terminal are still working.

I noticed that CtrlAltarrow doesn't show in the list with "unity shortcuts" (the list that shows when you hold the super key).

Does anyone know how to re-enable this way of workspace switching?

I enabled workspaces in the appearance menu. It doesn't have any effect though. Switching via the workspace-switcher in the unity dash works fine though.

CCSM is installed, but I can't seem to find a way to add keyboard bindings there.

System: ubuntu 13.04 64bit

  • I didn't state it, but I enabled workspaces in the appearance menu. It doesn't have any effect though. Switching via the workspace-switcher in the unity dash works fine though.
    – woutervddn
    May 28, 2013 at 7:05
  • askubuntu.com/questions/83176/…
    – Mukund
    May 28, 2013 at 7:15
  • Amras, I've got CCSM installed but can't find a single setting regarding the workspace switcher. Where do I find it?
    – woutervddn
    May 28, 2013 at 7:51
  • Does workspace switching currently work, using mouse? (Yes, I know you said it is enabled.)
    – david6
    May 28, 2013 at 8:34
  • What graphics chipset/card? Is this Ubuntu 64-bit (or 32-bit)?
    – david6
    May 28, 2013 at 8:35

3 Answers 3


I had this same issue. I enabled workspace from Appearance → Behavior, and also tried using Ubuntu Tweak, but no go on the keyboard shortcuts, even though all the defaults were there.

I then opened CCSM to make sure that the Desktop Wall was enabled. In my case it wasn't, and as soon as I enabled it, my keyboard shortcuts started working again.

  • 1
    Thx! I must have looked over it, Enabling Desktop Wall fixed it :)
    – woutervddn
    Jun 1, 2013 at 8:25
  • 10
    CCSM is Compiz Config Settings Manager for those wondering. It can be installed by looking for the compizconfig-settings-manager package in Ubuntu 16.04 and (probably) newer versions.
    – devius
    Feb 20, 2017 at 14:47
  • 11
    Installing compizconfig-settings-manager and enabling Desktop Wall fixed the issue. Mar 10, 2017 at 12:47
  • 1
    Can confirm that the issue randomly occurred for my ubuntu 16.04 (upgraded from 14.04 with an existing user account) installation and that compizconfig-settings-manager could fix it. Issue only exists for existing user accounts, guest sessions are not affected.
    – corny
    Mar 28, 2017 at 15:40
  • Thanks, it worked. Can you please mention what exactly does this ccsm setting refer to Aug 9, 2017 at 9:47

This may help.

On my system, the same thing was happening. I found, by checking the Keyboard>Shortcuts>Navigation that it's not Ctrl + Alt + Arrow, you haveto press Ctrl + Alt + shift+arrow perhaps the C+S+A is being used bu another programme so conflicts.

  • tried it.. even tried ctrl + alt + shift + q to go to the workspace on the right.. Didn't work..
    – woutervddn
    May 28, 2013 at 8:01
  • Another way is Super + S May 28, 2013 at 9:34

On Ubuntu 13.04 workspace are disabled by default. To enable it open 'Appearance' from system settings > click to the 'Behavior' tab > check 'Enable workspace'. And also check the keyboard shortcuts in system setting>keyboard.

  • Both "enable workspace" option and the proper keyboard shortcuts are present..
    – woutervddn
    May 28, 2013 at 7:49
  • 1
    Not sure why this got voted down (presumably not by the asker either, as their rep is too low), so I've voted it back up to zero. The only thing I could add to this answer is to check in the compizconfig-settings-manager (you may have to install it first) to ensure that the keyboard binding exist in there, as I think that's where the keyboard-shortcuts takes its config from.
    – Scaine
    May 28, 2013 at 9:01
  • Scaine: I've got ccsm installed, but I can't seem to find where I cand bind the keyboard? I find mouse bindings for hotcorners, but that's about it..
    – woutervddn
    May 28, 2013 at 9:15
  • This, not the other answers (checked) was the correct answer for me on Ubuntu 16.04.
    – tsbertalan
    Aug 17, 2017 at 15:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.