I have updated my ubuntu from 12.10 to latest Ubuntu 13.04. everything is fine but when i go to Places and click any place, it opens in Disk Usage Analyzer by default and i found no way to either stop Disk usage analyzer permanantely or to change the default Application for Places. Please tell me how to set it default so that Places opens properly.

Please see the image, I open Places > Music folder but it opens in Disk Usage Anylyzer

I found similar question but the solution doesn't works for me as I do

edit /usr/share/applications/baobab.desktop and change




and now everything opens in sublime-text

Note: I have many changes while i was using ubuntu 12.10 , still i am using session fallback desktop theme in latest ubuntu. does that affect?


4 Answers 4


I had this problem on 14.04 using the gnome-session-fallback desktop. After trying the other solutions (removing MimeType=inode/directory; and editing /usr/share/applications/mimeinfo.cache) what actually fixed the problem was to run this command as your user:

xdg-mime default nautilus.desktop  inode/directory

By default it is set to use nautilus-folder-handler.desktop, which for some reason ends up launching the dreaded baobab.

  • Happened again for me on 16.04, this works.
    – Rmano
    Nov 3, 2016 at 9:45
  • not working on 21.04 Sep 24, 2021 at 18:09

When I went to https://bbs.archlinux.org/viewtopic.php?pid=1186209#p1186209 I've found the solution in there. Remove MimeType=inode/directory; from /usr/share/applications/baobab.desktop and run as root

update-desktop-database -q

I'm running Kubuntu 17.10 and had a similar problem (in my case, it opened git-cola). Thanks to richq's answer I figured out the problem, but the solution different enough to warrant a separate answer:

Open File Associations (if plasma search doesn't find it: System Settings under Applications).

Expand inode and find directory - type it in the top-left search to filter out the rest:

File Associations screen

In Application Preference Order, select the application you want to use.

If it isn't at the top already, move it up, click Apply and see if this fixes things.

Otherwise, click Edit..., and open the application tab.

The Command field (fourth from the top) is probably not pointing to the actual program, so fix that. Make sure you keep the %U at the end!

For example, for Dolphin, it should probably look like this:

Edit command path to Dolphin

If you do not know where your desired application is stored, open a terminal and run whereis <application> (it's probably in /usr/bin/).

Anyway, that fixed it for me, hopefully this works for others too.


I had the same problem when occasionally removed nautilus.

Trysudo dpkg-reconfigure nautilus

  • not solved by this :(
    – xkeshav
    May 28, 2013 at 9:46
  • but you have nautilus installed? sudo apt-get install nautilus
    – dds
    May 28, 2013 at 9:53
  • gives nautilus is already the newest version. The following packages were automatically installed and are no longer required: linux-image-3.8.0-19-generic linux-image-extra-3.8.0-19-generic webaccounts-extension-common
    – xkeshav
    May 28, 2013 at 10:42
  • this solution doesn't work with my ubuntu
    – xkeshav
    Jun 6, 2013 at 5:54
  • also not working here with 21.04 Sep 24, 2021 at 18:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .