4

I'm using an Intel mother board (D865G SA), about a 2006 vintage, and using the built in video port. The video chip is Intel 865G Extreme Graphics 2. Previous versions of Xubuntu looked normal, but with 13.04 I seem to have degraded color depth. For example, the stock wallpapers are gradient images, and they appear with 'banding'. Also, any video looks really bad. I tested 13.04 on a new Acer laptop and it looked great, and I checked the color palette settings to compare with the one I'm having trouble with, and they were the same. I would guess the diagnostic process would consist of identifying whether or not this video device is still supported, then move on to identify if the video driver is faulty, missing or incorrect. Any suggestions to put me on the right track? Thanks in advance.

1
  • I am having the exact same problem with an Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01) – nak May 29 '13 at 6:15
1

It seems like there was a video driver issue, I compiled the latest xf86-video-intel driver from the git repo --- (here is the exact tar.gz I downloaded).

NOTE: If you don't want to do all this craziness and want to try this PPA of the git repo instead feel free: http://www.ubuntuupdates.org/ppa/xorg-edgers They just warned me that I should install ALL of the things, so I took their advice and built the driver in my environment.

This guide might work, but here are the steps I remember taking:

$ tar xvfz xf86-video-intel-2.21.8.tar.gz
$ cd xf86-video-intel-2.21.8/
$ sudo apt-get install autoconf libtool xutils-dev xserver-xorg-dev
$ ./autogen
$ ./configure # This might not be necessary, but I ran it...
$ sudo make install

I then uninstalled the current drivers through the software center, you can probably just do an $ apt-get remove xserver-xorg-video-intel

THEN the moment of truth... $ sudo killall Xorg to restart X and load our new drivers (At least I think that's what happened hehe)

Either way, the gradients look smoother, I haven't even tried watching a video on this computer yet.

Hope this helps :)

0

This is how i solved it on my Xubuntu 13.04 After finding out that the colordepth was 16, and I needed 24, I had too change xorg.conf, but xorg.conf did not exist in /etc/X11/xorg.conf so this had to be created. Press ctrl+alt+F6 This will enter a terminal for you.

Type in terminal:

    sudo stop lightdm

This will shutdown your desktop environment

    sudo Xorg -configure

This will give you a new file called xorg.conf.new

backup your old xorg.conf if it exist and cp this .new file into /etc/X11/xorg.conf

    sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

    sudo mv xorg.conf.new /etc/X11/xorg.conf

Now start a new desktop service

    sudo start lightdm

This worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.