0

Hey guys, I am currently running 10.10 - 32 bit on a new Thinkpad W510 with nVidia Quadro FX 880M graphics card. I am running with the default graphics drivers that installed with ubuntu install.

My problem is that when I am logging in the screen acts normally as far as birghtness is concerned. I can increase/decrease brightness with Fn keys. But few seconds after I log in screen goes pitch dark. Hitting Fn+Home flickers the screen to all the way bright, then all the way dark. This behavior continues until I reach maximum brightness, in which case the screen stays all the way bright, for a few more seconds and then again goes dark if there is no activity & the cycle continues.

Have you guys faced any of these issues? If so any pointers on how to resolve it. I am not alone, on ubuntu forum I saw another person having the same issue - link but no solution.

Please help!

UPDATE

I followed the instructions that htorque mentions in his answer and it worked.

UPDATE 2

After a while the issues cropped again. This time I bit the bullet and installed the nVidia's official graphics drivers (via System > Admnistration > Additional Drivers) and the issue seems to have gone. The UI seems more snappier as well.

1 Answer 1

4
  • Press Alt + F2 to get the run dialog → type gnome-power- preferences and click on Run

  • On the On AC Power tab there is an option Dim display when idle that does exactly what it says → untick it and click on Make Default:

    enter image description here

  • On the On Battery Power tab there is above mentioned option and another one (Reduce backlight brightness) for automatically reducing backlight brightness when on battery → untick both and click on Make Default:

    enter image description here


There's another thing that was getting on my nerves with my ThinkPad T510: different backlight levels for GDM and session → read this question to find out how to completely stop gnome-power-manager from manipulating the backlight brightness.

1
  • Thanks! I am looking into this now. Will report back with update.
    – Chantz
    Commented Mar 12, 2011 at 20:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .