I have an Irvine (which may actually be Huawei) 3g USB modem. I live in India. I use ubuntu 12.04. I am using an airtel SIM card in the modem.

On plugging in the modem, it shows up in 'Edit Connections'. However, there is no option to connect to it in the list of available networks displayed on clicking the network icon (the one in the shape of a sector of a circle).

I have usb-modeswitch and usb-modeswitch-data already installed.

Here's the extra line in the output of lsusb when the modem is present :
Bus 002 Device 005: ID 20a6:f00e

I have also attempted the instructions on this page - 3G USB Modem Not Working in 12.04; and it's still not working! I've tried the modprobe, the echo to usbserial, and wvdial (which didn't detect any modem).

Could anyone please give me ideas on what I could try next ?

Here's the relevant lines from usb-devices -

T: Bus=02 Lev=01 Prnt=01 Port=03 Cnt=01 Dev#= 6 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=20a6 ProdID=f00e Rev=00.00
S: Manufacturer=Modem
S: Product=Modem Device
S: SerialNumber=000000000002
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage

As you can see, it's detecting it as a modem, but perhaps using the usb-storage driver.


I found a procedure on some Internet forums. It has worked for me with the new Ubuntu 13.10 saucy.

At terminal execute the following

sudo eject sr1
sudo modprobe usbserial vendor=0x20a6 product=0x1106

This will detach the usb_storage device at sr1(cdrom) and enable the usb serial ports for the modem. By some reason this will only work once. If you remove the dongle and connect again the first line will not work.

Also it takes about a minute to the NetworkManager detect the new modem device. After the detection a new network option like 3g broadband will show up in the connections menu. Enabling it will allow you to create a new connection to your provider.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.