68

I want my primary display be at the right and my TV (additional) be at the left.
In that case new windows shall appear at the TV.

Can I somehow set where new windows will appear ?

18 Answers 18

63

Turn off the current Primary monitor in "Displays" application and apply.

The secondary monitor will become the Primary. Then simply turn the old primary monitor again to have both displays active again.

|improve this answer|||||
  • 5
    How do I do that? – Braiam Dec 6 '13 at 20:00
  • 3
    nice hack, only solution that worked for me – Dominik Goltermann Jan 21 '14 at 9:39
  • 10
    That doesn't do the trick. What you are doing with that is essentially the same as dragging the monitor you want to be the primary to the left side. It's ok if you want it to be on the left. But if you want it to be on the right you'll have to drag it to the right at the end of your procedure...which makes the left one the primary again. – mmalmeida Feb 24 '15 at 9:44
  • 11
    I've reported this at bugs.launchpad.net/unity/+bug/1425000 – mmalmeida Feb 24 '15 at 10:16
  • 3
    Doesn't work, just like the two other answers. – arekolek Dec 21 '15 at 9:41
26

The only correct answer here is unfortunately a buried comment:

I've reported this at https://bugs.launchpad.net/unity/+bug/1425000 – mmalmeida

It seems that the primary one (at least in 14.04) is always the one closest to the top left. So, there's no way to make the "right" display the primary one. Editing ~/.config/monitors.xml makes no difference.

(As this question pre-dates 14.04, I'm guessing this has been an issue for a while now)

|improve this answer|||||
  • 1
    The bug is also in 12.04. No way to get the right monitor to be the primary. – mivk Nov 14 '15 at 9:35
20

For what it's worth at this point, you can adjust which monitor is the primary by dragging the menu bar from one monitor to the other.

  • Go to System Settings > Displays
  • Hover over the menu bar on your secondary monitor
    • Click and drag it over to your preferred primary
  • You can also adjust the Launcher Placement dropdown to reflect which monitor you want it on, or on all monitors if you prefer.
  • Click Apply

Before Adjustment After Adjustment

|improve this answer|||||
  • 4
    This should be the accepted answer! The others are, at best, workarounds. – k0pernikus Dec 9 '15 at 11:08
  • 1
    Doesn't work for me on 14.04. Say I have a focused window on my (intended) primary screen, switch workspaces, then switch to the previous workspace. Now the window doesn't have the focus anymore, because the "secondary" screen steals focus, i.e. it is indeed primary despite applying these instructions. – arekolek Dec 21 '15 at 9:21
  • launcher placement is the trick here.that means any app that you launched will up in your monitor that you specified in launcher placement – erginduran May 7 '17 at 20:14
  • For Ubuntu 17.10 this answer did the job. Quick and simple – thomas77 Mar 7 '18 at 19:25
  • I did not realise I could drag that. Thank you – wakjah Aug 28 '18 at 9:35
18

The following answer enables the monitor on the right to be the primary monitor (Ubuntu 14.04)

The key idea is to edit "~/.config/monitors.xml” with your favorite editor.

Identify you main monitor (name, resolution, etc) and change “no” into:

<primary>yes</primary>
|improve this answer|||||
  • 2
    Just remember to set no to the former monitor :D – Rael Gugelmin Cunha Feb 5 '15 at 13:58
  • Doesn't work for me, just like the other answer. Restarting my session with ctrl+alt+backspace didn't help. – arekolek Dec 21 '15 at 9:33
  • 1
    Worked for me :) – janw Aug 9 '16 at 10:15
  • 1
    Ubuntu 16.04.1. My monitor (on the right) was already marked <primary>yes</primary>, and new windows still open on the laptop display (which is on the left). – Dan Dascalescu Sep 12 '16 at 4:04
  • 2
    @Joschua: I gave up and solved this software bug with a hardware solution: moved my laptop to the right of the monitor. – Dan Dascalescu Sep 24 '16 at 22:41
9

If you are running an Nvidia card (with Nvidia drivers), you can use their settings tools to set the primary monitor. The Nvidia drivers have more options than the native Ubuntu monitor configuration.

  1. Run the following command to start the Nvidia Settings Configuration

    sudo nvidia-settings
    

    If this command isn't found, this solution will not work until you install the Nvidia drivers.

  2. Select the "X Server Display Configuration" tab on the left.

  3. Select the monitor you want to be primary (in my example, I want the LGD display to be primary).

  4. Check the "Make this the primary display for the X screen" checkbox, then hit "Apply".

  5. Quit the settings window, then run this to make this change persistent through reboots:

    sudo nvidia-xconfig
    

I had this issue before, and I had some wacky monitor setups. This has always worked for me (on 16.04 right now), hope it will work for anyone else out there with Nvidia!

|improve this answer|||||
7

If I'm not mistaken if you do the following

  • Click on the Power button enter image description here
  • Go into the Display menu
  • Rearrange your two monitors in the way you like by dragging the highlighted screens as below (there will be 2 in your case):

enter image description here

  • And then making sure the launcher placement is on your primary screen, then should do the trick I'd assume.
|improve this answer|||||
  • 4
    In that case primary wll be the left! I want my primary display be at the right! – emoxam May 27 '13 at 14:41
  • If I'm not mistaken (can't try this right now unfortunately) you can drag the displays (as in the red Laptop and Green other screen in your case) around to have the primary on the right. And after changing the launcher placement it should work, did you give it a try? – Oyibo May 27 '13 at 14:44
  • Ok, i have two monitors, i make my TV at right, and monitor at left, all windows moved to TV, i get them back to monitor by hands, and now i have a problem - i have the upper panel on every display and pidgin shown only on TV;s panel tray. That what i am about, why pidgin's icon at the TV only ? (I guess i will have similar problems from time to time) – emoxam May 27 '13 at 15:48
2

Another way using XRANDR command

  1. Check for available connections names

    xrandr

    Screen 0: minimum 8 x 8, current 2806 x 900, maximum 32767 x 32767
    LVDS1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
       1366x768      60.07*+  40.02  
       1360x768      59.80    59.96  
       1280x720      60.00  
       1024x768      60.00  
       1024x576      60.00  
       960x540       60.00  
       800x600       60.32    56.25  
       864x486       60.00  
       640x480       59.94  
       720x405       60.00  
       680x384       60.00  
       640x360       60.00  
    DP1 disconnected (normal left inverted right x axis y axis)
    DP2 disconnected (normal left inverted right x axis y axis)
    DP3 disconnected (normal left inverted right x axis y axis)
    HDMI1 disconnected (normal left inverted right x axis y axis)
    HDMI2 disconnected (normal left inverted right x axis y axis)
    HDMI3 disconnected (normal left inverted right x axis y axis)
    VGA1 connected 1440x900+1366+0 (normal left inverted right x axis y axis) 370mm x 230mm
       1440x900      59.89*+  74.98  
       1280x1024     75.02    60.02  
       1280x800      59.81  
       1152x864      75.00  
       1024x768      75.08    70.07    60.00  
       832x624       74.55  
       800x600       72.19    75.00    60.32    56.25  
       640x480       75.00    72.81    66.67    60.00  
       720x400       70.08  
    VIRTUAL1 disconnected (normal left inverted right x axis y axis)
    
  2. So as you see LDVS1 connected primary, to change VGA1 as primary run:

    xrandr --output VGA1 --primary

    Check again:

    xrandr

    Screen 0: minimum 8 x 8, current 2806 x 900, maximum 32767 x 32767
    LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
       1366x768      60.07*+  40.02  
       1360x768      59.80    59.96  
       1280x720      60.00  
       1024x768      60.00  
       1024x576      60.00  
       960x540       60.00  
       800x600       60.32    56.25  
       864x486       60.00  
       640x480       59.94  
       720x405       60.00  
       680x384       60.00  
       640x360       60.00  
    DP1 disconnected (normal left inverted right x axis y axis)
    DP2 disconnected (normal left inverted right x axis y axis)
    DP3 disconnected (normal left inverted right x axis y axis)
    HDMI1 disconnected (normal left inverted right x axis y axis)
    HDMI2 disconnected (normal left inverted right x axis y axis)
    HDMI3 disconnected (normal left inverted right x axis y axis)
    VGA1 connected primary 1440x900+1366+0 (normal left inverted right x axis y axis) 370mm x 230mm
       1440x900      59.89*+  74.98  
       1280x1024     75.02    60.02  
       1280x800      59.81  
       1152x864      75.00  
       1024x768      75.08    70.07    60.00  
       832x624       74.55  
       800x600       72.19    75.00    60.32    56.25  
       640x480       75.00    72.81    66.67    60.00  
       720x400       70.08  
    VIRTUAL1 disconnected (normal left inverted right x axis y axis)
    
|improve this answer|||||
2

Solution: I know this is an old thread but the solutions posted here didn't work for me on Ubuntu 16.04 (but the xrandr answer posted here helped point me in the right direction) For posterity and to help other people searching for an answer...

A full answer that fully solved this problem for me can be found at the following link if it helps anyone else who is struggling with this issue: Set primary monitor on 16.04

|improve this answer|||||
  • 5
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Karl Richter Aug 12 '16 at 8:22
2

In Ubuntu 17.04 I was able to change the primary display, via the settings > Devices > Displays and change the primary display option to your extended display.

|improve this answer|||||
  • I confirm this feature is working well also in Ubuntu 18.04.1 LTS. Open "Displays" application, go to display arrangement, and in the lower bar of this frame, there you'll find "Primary Display" - select and enjoy! – Hartmut P. Aug 21 '18 at 9:59
2

In Ubuntu 18.04 its possible but hard to find. Under "Settings->Devices->Screen Display" one may find a section called "Primary Display". You can actually click on the label, although there is no indication.

enter image description here

|improve this answer|||||
1

In Ubuntu 18.04 there is an option to set the primary display.
Devices>Display Arrangement>Primary Display.

There is also an extension if you want to quickly switch between display modes. https://extensions.gnome.org/extension/1030/display-switcher/

|improve this answer|||||
0

Yes. Start System settings, click on Displays then drag the monitors so that they are where you want them to be.

|improve this answer|||||
  • 2
    In that case primary wll be the left! I want my primary display be at the right! – emoxam May 27 '13 at 14:39
  • Then drag it to the right hand side. – SimplySimon May 27 '13 at 14:55
  • Ok, i have two monitors, i make my TV at right, and monitor at left, all windows moved to TV, i get them back to monitor by hands, and now i have a problem - i have the upper panel on every display and pidgin shown only on TV;s panel tray. That what i am about, why pidgin's icon at the TV only ? (I guess i will have similar problems from time to time) – emoxam May 27 '13 at 17:02
0

For people running the newer versions (working on 16.04), you can easily change the position of your monitors by drag-drop. The leftmost display will become your primary display.

For example - I've my laptop connected to external display which is placed on the left on my desk. So I've to drag the external display icon (see in image) from the right to the left of Built-in display.

Change monitor position

|improve this answer|||||
  • In Ubuntu 18.04 Unity, dragging to the left does not make it a main display. – tartaruga_casco_mole Apr 27 '18 at 21:42
  • Not using Ubuntu anymore but I think they've moved to Gnome now – Divyanshu Maithani Apr 28 '18 at 8:36
0

In Ubuntu 18.04.3 LTS (gnome) go to Settings > Devices > Displays > Primary Display

|improve this answer|||||
-1

Yes, there is a "default monitor" setting, and it's usually accessible from the Graphics Utilities Control Panel. So look for or install your Nvidia or ATI cards control panel software.

|improve this answer|||||
  • Would you please provide me a screenshow ? I can't find it in a amdcccle util. – emoxam May 27 '13 at 14:40
-1

I'm using kubuntu 13.04, live with 2 Gb persistence. I have a laptop with a 2nd monitor on the left. The Displays Setting worked perfectly (Take that! Debian 7 Live, Fedora Live!) but then windows would open on my 2ndry monitor. I opened display settings, set the the 2nd mon as primary, hit Apply, then set my primary mon as primary, hit Apply, & all works fine.

|improve this answer|||||
-1

I got the trick. In the Display setting you see both scree BUT the primary display have a title bar with the date at the up. You need to click on this bar and drag it to the monitor you want primary. Apply et voila

|improve this answer|||||
  • 3
    This answer doesn't add anything useful. drunkScientist already gave the same answer, and there was already a reply that it's wrong. – Dan Dascalescu Sep 12 '16 at 4:06
-2

you might be looking to click on that little black bar on the monitor selection pic above, sets where the menu is, which seems to also be the default monitor. worked for me with 12.04 and gnome

|improve this answer|||||
  • 2
    no, this is not a default monitor. Even if unity panel is displayed only at the left, right monitor still is considered as primary. For instance truecrypt window when launched appears on it, instead of left monitor – user907860 Feb 17 '14 at 11:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.