19

I have recently installed vlc remote in my phone and I can't use it unless vlc is opened so I was wondering if it is possible to always keep VLC opened like skype and utorrent in windows,
Thanks in advance,

1

5 Answers 5

22

With version 2.1.6 'Systray popup when minimized' option doesn't exist anymore. To hide vlc simply click on the vlc systray icon.

4
  • 1
    huh, so simple and I couldn't figure out. Is there no in-app control for that btw? Commented Aug 10, 2015 at 8:40
  • 2
    Works great in Windows, VLC 2.1.5. Thanks for sharing & +1.
    – Devner
    Commented Feb 7, 2016 at 6:48
  • 1
    Also works with Fedora and VLC 3.0 git.
    – luca76
    Commented Oct 9, 2017 at 7:15
  • Sweet! It also works on KDE Plasma.
    – cpprust
    Commented Mar 30, 2023 at 2:58
8
  1. Go to Tools>Preferences
  2. Under interface you will find two options to mark, I have marked them for you in this image: preferences window of VLC

Check "Systray popup when minimized" Check "Show systray icon"

3. Close VLC.

4. Now open it using:

vlc --qt-start-minimized

Hope this works for you.

6
  • 2
    For added convenience, put that command in your start up applications so you don't need to remember to launch it every time. Commented May 27, 2013 at 12:08
  • Is "Systray popup when minimized" option removed or is it ubuntu specific? Can't find on windows. Running 2.1.3 Commented May 27, 2014 at 17:26
  • Should be cross platform, but I can't check since I have no windows machine at hand
    – GuySoft
    Commented May 27, 2014 at 21:40
  • No luck at finding it at windows :) Is it still available in 2.1.3 on ubuntu? (I on the other hand only use Debian box without gui ;) Commented May 28, 2014 at 6:55
  • 1
    it changed to 'show media change popup:' with options: when minimized, always, or never. (on windows and ubuntu, but it's not critical to minimizing)
    – Ohad Cohen
    Commented Jan 17, 2015 at 0:39
7

For newer version of VLC you'll have to right click the icon in systray and select "Hide VLC media player in taskbar".

3
  • 1
    Thank you for providing the only working solution for current VLC versions Commented Sep 1, 2017 at 13:59
  • 1
    Double-clicking the VLC icon on the systray will show/hide the VLC window (at least on GNOME 3). It took me a while to discover it... Commented Jan 10, 2021 at 22:21
  • @JuliánLanderreche: Thank you for the tip! it is way better than other solutions
    – user545149
    Commented Nov 9, 2021 at 11:42
3

I think, you need for background music play and you anyways get the controls on-screen while playing video. The latest version VLC Media Player does not have the option of 'Systray popup when minimized' and in my case, the systray icon is also not shown. So, I came up with another idea of using something which Linux provides by default. I used two workspaces.

One is for my works and other where the VLC is running but you still get the controls in the Sound Systray Icon.

Following pictures show how I am managing:

VLC Media Player on Workspace 2:

enter image description here

The control of the VLC Media Player in my workspace:

enter image description here

1

Nowadays it is inside the QT menu:

Image

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .