I installed flux from the Kilian PPA, which installs fine. i run the app and the icon displays in the tray.

however, when i try to set my preferences, the menu does not ever appear. i found the flux log in /tmp and am hoping someone here can decipher it for me

Traceback (most recent call last):

  File "/usr/lib/pymodules/python2.7/fluxgui/fluxgui.py", line 381, in <module>
    app = Fluxgui()

  File "/usr/lib/pymodules/python2.7/fluxgui/fluxgui.py", line 22, in __init__
    self.settings.zipcode, self.settings.color)

  File "/usr/lib/pymodules/python2.7/fluxgui/fluxgui.py", line 48, in start_xflux
    self.xflux = pexpect.spawn("/usr/bin/xflux", args)

  File "/usr/lib/python2.7/dist-packages/pexpect.py", line 430, in __init__
    self._spawn (command, args)

  File "/usr/lib/python2.7/dist-packages/pexpect.py", line 560, in _spawn
    os.execv(self.command, self.args)

OSError: [Errno 2] No such file or directory

3 Answers 3


It is missing ia32-libs dependencies.

sudo apt-get install ia32-libs

will do the trick.

The problem is that the binary file /usr/bin/xflux is is expected to run with 32 bits libs, so it doesn't work in a 64 bits Ubuntu without the explicit inclusion of the ia32-libs package.

  • 1
    Upvoted since this clued me in to the problem. However, this no longer works. See my answer below.
    – Johann
    Apr 7, 2014 at 4:31

Just got this error in Ubuntu 13.10, where ia32-libs is no longer available. It appears the solution today is to either manually repackage fluxgui with the new 32-bit packages, or install ia32-libs from the 13.04 repository (not recommended). See: https://askubuntu.com/a/394156/50450.

I ended up just grabbing the pre-built 64-bit CLI daemon from http://justgetflux.com/linux.html which worked out of the box (Xbuntu 13.10).


There doesn't appear to be quite enough information here, but can you do:

ls /usr/bin/xflux

From the traceback, I assume that file is missing. If it is, run

sudo updatedb && locate xflux

if it isn't found, remove/reinstall fluxgui, if it is, symbolic link it to /usr/bin/xflux with ln -s

If that file DOES exist, then I am not sure my friend.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.