I have just upgraded my Dell Inspiron 1545 laptop from Ubuntu 12.04 to 13.04. Unfortunately the top bar now has a little red circle with a minus sign in it. When I click it, it opens a box with the following message in it:

An error occurred, please run Package Manager from the right-click from the right click window or apt-get in a terminal to see what is wrong. The error message was: 'Unknown Error:''(E:The package google-chrome-stable needs to be reinstalled, but I can't find an archive for it.)'This usually means that you have >installed packages with unmet dependencies

I don't have a lot of experience using ubuntu, or linux in general, and I don't know what this means. It sounded to me like some kind of google chrome error. I had downloaded and installed google chrome only a few minutes before. I ran apt-get in the terminal but it didn't do anything, and I had no idea what run the Package Manager from the right click window meant. Google chrome and the geany ide are the only sofware I have installed since installing linux. The computer seems to be running perfectly fine. Do you have any suggestions on what I should do?

The results from: sudo apt-get -f install are:

E: The package google-chrome-stable needs to be reinstalled, but I can't find an archive for it.

  • 3
    Please run sudo apt-get -f install in a terminal and paste the results in your question, thanks! – Jorge Castro May 27 '13 at 1:40

It seems that google-chrome-stable have broke your system for some reason. Try this: Open your terminal window


Then right there type commands (after each command type enter and respond yes to questions)

sudo apt-get remove google-chrome-stable 

Then update the system via

sudo apt-get update && sudo apt-get upgrade

Let apt-get run and if there is any error post as comment here and I will help (or anyone available)

If the Commands fails you can try these ones: Update Packages

sudo apt-get update

clean the downloaded packages (where there might be broken ones)

sudo apt-get clean

Remove unneeded packages (careful! If it might list something that is needed but its dependency or such have been removed and left it orphan)

sudo apt-get autoremove

Reconfigure all packages

sudo dpkg --configure -a

Fix broken packages

sudo apt-get install -f
  • When I ran sudo apt-get remove google-chrome-stable, I got the same error message as when I ran studo apt-get -f install. Thanks! – James May 27 '13 at 19:36
  • Just right now. It removes the said package. I have updated the answer – Stefano Mtangoo May 27 '13 at 19:37
  • do you have synaptic installed? – Stefano Mtangoo May 27 '13 at 19:39
  • As far as I know I don't have synaptic installed. I searched for it and it did not pull anything up. – James May 27 '13 at 19:42
  • I just ran sudo apt-get remove google-chrome-stable again, and then ran audo apt-get update && sudo apt-get upgrade. The last four lines of the process were: Errors were encountered while processing: google-chrome-stable E: Sub-process /usr/bin/dpkg returned an error code (1). But the little red circle on the top bar is gone now. Is every thing fine? – James May 27 '13 at 19:45

Removing the packages list and updating solved the issue for me

Open the terminal: Ctrl+Alt+T

Remove the package list:

sudo rm -vf /var/lib/apt/lists/*
  • -v, --verbose explain what is being done

  • -f, --force ignore nonexistent files and arguments, never prompt

Update the packages:

sudo apt-get update
  • This is the only one working with me. – Islam Hassan Nov 4 '16 at 6:22

Fixing the problem with Software Center

When I encountered the same problem (not sure which application caused the problem), running Software Center gave me the option to repair dependencies (in fact it forced me to do so because it would be 'unable to install other software until the problem was fixed'). It worked without problems, and the error sign in the notification area disappeared.

Not the answer you're looking for? Browse other questions tagged or ask your own question.