4

I have a Core i5 with an Intel HD 3000, and i use Ubuntu 12.04 x64 with kernel 3.5.0-18, and PPA xorg-edgers for video drivers.

And i think after last update, apps are crashing a lot:

VLC won't play videos, Minecraft won't run, Netflix with modified wine won't run either.

Even glxinfo or glxgears won't run.

Here's the console output:

glxinfo

name of display: :0.0
Gen6+ requires Kernel 3.6 or later.
glxinfo: ../../../../../src/mesa/main/context.c:1545: _mesa_make_current: Assertion `newCtx->Version > 0' failed.
Aborted (core dumped)

glxgears

Gen6+ requires Kernel 3.6 or later.
glxgears: ../../../../../src/mesa/main/context.c:1545: _mesa_make_current: Assertion `newCtx->Version > 0' failed.
Aborted (core dumped)

If you need more info, like that core dump, just tell me where to find it and i post it here.

So should i update my kernel to a newer one, wait for a driver update, or change video driver?

6

There's a 3.8 kernel available for Ubuntu 12.04, it should work.

sudo apt-get install linux-generic-lts-raring
  • The thing is, i use VMware Workstation 9.0. Will i need to reinstall it in order to work with the new kernel? – ThiagoPonte May 27 '13 at 19:57
  • I know almost nothing about VMware. I know that VirtualBox and many other software that require reinstallation of kernel modules at every kernel update can automate this process if dkms is installed. VMware should be smart enough to use dkms too, but you'll have to test it yourself. – Eric Carvalho May 28 '13 at 1:27
  • I'm depending on VMware right now, so i can't update right now, but i accepted your answer. – ThiagoPonte May 29 '13 at 2:13
  • Your solution is right. xorg-edgers now require at least kernel 3.6. launchpad.net/~xorg-edgers/+archive/ppa "If you are using precise on a 965 or newer intel, be sure to install linux-generic-lts-raring as mesa now requires a 3.6 kernel!" – ThiagoPonte Jun 1 '13 at 20:14

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.