6

First off, I've read through this question: How can I install Minecraft?. I'm interested in the free web-embedded version (for demo purposes), not the paid and downloaded .jar file.

I removed the open-java whatever that Ubuntu prefers to use. I installed sun-java6-jre. Then I ran sudo update-alternatives --config java to ensure I was using Sun's Java. Restarted my browsers, then tried to start the game from: http://www.minecraft.net/play.jsp

It pops a prompt to make sure I really want to allow direct interaction between minecraft.net and my computer, I agree. The in browser display mumbles something about loading a library, then darkness. The page doesn't crash, ps shows the java plugin process, all seems well except the game doesn't load.

I see the same behaviour on Chromium 11.0.662.0 (73963) as Firefox 4 RC1.

6

Took a look at about:plugins on Chromium and noticed IcedTea was still being used for eris knows what reason. One apt-get purge icedtea6-plugin and I finally get to try this intriguing 8-bit(-ish) graphic game.

0

Are you using compiz? If so, try disabling it while loading the demo. Java has been known to not function well with compiz.

  • No compiz. In fact, usually no gnome, although I see the same behaviour when I try it in a gnome-session. WMFS or blackbox is the window manager of choice. – djeikyb Mar 11 '11 at 23:37

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.