1

I'm using a relatively new installed Ubuntu 13.04 with all updates. My video driver is installed from the official AMD website and worked before without trouble.

After the latest update, Unity did not start anymore (I think). The launcher and the top bar did not appear, so the only thing I could see was the background and the desktop icons (so nautilus was useable). But there was no Window frame around the windows, so I was not able to see the close-button and so on. I thought this is probably caused through the video driver (installed using amd-catalyst-13.4-linux-x86.x86_64.run installer file). So I ran it again.

Now, the frames around the windows are back. But the rest stayed as before.

Is it possible to get everything working again without installing everything new? I would also use the OpenSource or the proprietary video driver from software-properties-gtk, but it does not allow me to "downgrade" or choose the open source driver. If you need any additional information just tell me.

Thank you.

PS: I can imagine this was already answered, but I could not find any working answer and it would be good if I could use my computer normally soon.

Update: I changed to the open source driver using the instructions from an answer below, but functionally nothing changed. Unity still does not show up.

5

Remove video driver:

sudo sh /usr/share/ati/fglrx-uninstall.sh

sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

Remove your xorg.conf

sudo rm /etc/X11/xorg.conf

Reinstall xorg completely

sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:amd64

sudo dpkg-reconfigure xserver-xorg

Reboot

sudo reboot

This should bring Ubuntu's video drivers and x the same way as it would be a fresh install.

Reset Unity

dconf reset -f /org/compiz/
unity --reset-icons &disown
  • 2
    removing the video driver returns that nothing will be removed because none of the fglrx* packages installed. This is probably because I installed the driver using a .run script which is offered from AMD. Should I continue trying the rest of your solution? – verpfeilt May 25 '13 at 16:22
  • Try with sudo apt-get remove fglrx* and see if it works, but i don't think it will make any difference. also try thse 2 comands if that doesn't work sudo sh /usr/share/ati/fglrx-uninstall.sh sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* – Mihai May 25 '13 at 16:34
  • Thanks, there was really a uninstall.sh, so this command worked. After rebooting the open source driver is used (according to software-properties-gtk). Unfortunately, Unity still does not work. Everything stays the same. Maybe there is some way to find the error in some log file or just reinstall/configure unity completely? – verpfeilt May 25 '13 at 16:52
  • Ok i have edited my answer. Afther the .sh worked, you continued running the commands from "Remove your xorg.conf" and the rest from my inital post? – Mihai May 25 '13 at 16:56
  • Yes I followed everything. But the second command "sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*" also resulted in removing nothing. The uninstall script seemed to work , it even removed the xorg.conf itself. – verpfeilt May 25 '13 at 16:59
0

Go to the compiz manager and enable the unity plugin, this worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.