Actually this is an answer. Im not asking a question. Last day, I tried to install skype 4.2 on my dell N5110 with nvida Optimus, after the installation when I tried to open skype from dash it didn't open. So then I opened it with Terminal via skype and it gave me an error error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

So I did the following steps with the help of method mentioned in this link.


  1. Open a terminal and type sudo nano /etc/ld.so.conf.d/skype.conf
  2. Add the code /usr/lib/i386-linux-gnu/mesa/ in the next console window, and press ctrl+x to exit, when prompted enter y to say yes
  3. And finally run sudo ldconfig -v

Try this:

Install the package libgl1-mesa-glx:i386

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libgl1-mesa-glx:i386

Launch Skype via:

LD_PRELOAD=/usr/lib/i386-linux-gnu/mesa/libGL.so.1 skype &

You can put the last statement into a shell script, e.g. ~/bin/skype , or create a .desktop-File with this content:

Exec=LD_PRELOAD=/usr/lib/i386-linux-gnu/mesa/libGL.so.1 skype



Try this (NVIDIA Optimus Ubuntu 13.10):

$sudo update-alternatives --config i386-linux-gnu_gl_conf

  Selection           Path                                      Priority   Status
* 0            /usr/lib/nvidia-331/alt_ld.so.conf         8604      auto mode

  1            /usr/lib/i386-linux-gnu/mesa/ld.so.conf    500       manual mode

  2            /usr/lib/nvidia-331-prime/alt_ld.so.conf   8603      manual mode

  3            /usr/lib/nvidia-331/alt_ld.so.conf         8604      manual mode

Press enter to keep the current choice[*], or type selection number: **1** (Choose native value 1)

$  sudo ldconfig 
  • This worked for me with Bumbleebee installed on Ubuntu 14.04.1 LTS 64-bit. – Vesnog Jan 4 '15 at 0:05

Thomas R's answer is right, but the desktop file did not work for 14.04.1 LTS 64bit.

Here's what works for me:

  1. Edit file /usr/share/applications/skype.desktop
  2. Change the line Exec=env PULSE_LATENCY_MSEC=60 skype %U to Exec=env LD_PRELOAD=/usr/lib/i386-linux-gnu/mesa/libGL.so.1 PULSE_LATENCY_MSEC=60 skype %U
  3. Save file

Here's my complete skype.desktop file:

[Desktop Entry]
Comment=Skype Internet Telephony
Exec=env LD_PRELOAD=/usr/lib/i386-linux-gnu/mesa/libGL.so.1 PULSE_LATENCY_MSEC=60 skype %U

Have you tried to enter in the terminal:

 sudo apt-get update

and then enter in the terminal:

 sudo apt-get install libgl-mesa-glx:i386

and then enter in the terminal this:

 sudo dpkg-reconfigure -a /etc/ld.so.conf.d/Skype.conf

and it might work fine this way.

  • This will never work. – wakeup Dec 4 '14 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.