I am on 13.04 and waking from suspend takes me straight to desktop without a password prompt even though it is set to ask for a password in the brightness and lock settings.

Also I recently tried to lock my computer,going to the power menu in the top right corner and hitting lock,it does not do anything,I am still on the desktop..(just tried crtl alt l to lock,it does work) but not the way i did it though,but that is not important to me ,I need the password prompt after suspend..

Password prompts works only when booted from a shutdown...

  • 1
    On Brightness & Lock > Lock = ON ...try with it – Qasim May 25 '13 at 6:42
  • What DE do you use? The options differ. – mreq May 25 '13 at 6:42
  • the lock is on,if u read back in my first post – mark May 25 '13 at 17:23
  • Could you upload an screenshoot of your Brightness & Lock menu? – Lucio May 30 '13 at 19:50

Install gnome-screensaver

sudo apt-get install gnome-screensaver

  • 3
    No, don't use gnome-screensaver, use xScreenSaver instead. It's better, more used, and older (has more bugs taken care of). – RPiAwesomeness May 30 '13 at 19:40
  • nice thanks it works,I knew it was something ive installed recently,and one of them was cinnamon,when i installed the gnome-screensaver,it removed the cinnamon one..thanks – mark May 31 '13 at 5:31
  • 1
    Haa... thank you very much. Damned Cinnamon screensaver! – Victor Sep 14 '13 at 13:24

On ubuntu 13.10, macbookair 5.2, gnome-shell 3.8 I've had the same issue.

These have been the system settings:

  • gnome-control-center > brightness & lock > lock on and require password when waking from suspend enabled
  • dconf-editor > org/gnome/desktop/lockdown/disable-lock-screen disabled
  • dconf-editor > org/gnome/desktop/screensaver/lock-enabled enabled
  • dconf-editor > org/gnome/desktop/screensaver/ubuntu-lock-on-suspend enabled

This had no effect/didn't give any clues:

This made my day:

  • switching all the above mentioned keys in dconf-editor twice

So why? dconf bug? Or a combination of libnss-myhostname/gnome-screensaver/dconf? ... Didn't (want to) reproduce the problem and solution.


After a reboot, the non-locking behavior showed up again. I found out that after locking the screen either by keyboard shortcut (set via gnome-control-center) or by console (gnome-screensaver-command -l) the locking was restored. So adding gnome-screensaver & to startup applications solved the problem. Check ps -A | grep gnome-screen if gnome-screensaver is running.

  • 2
    the odd thing with that is, gnome-screensaver should be in the startup applications by default with Gnome. – Wilf Feb 12 '14 at 22:37

I had the same problem with Ubuntu 13.10 and Gnome 3.8. Found the solution in this post.

Gnome 3.8 no longer uses gnome-screensaver, but relies on gdm for screensaver functionalities, so you should install and use that instead of lightdm:

sudo apt-get install gdm

and select GDM when prompted. If GDM is already installed:

sudo dpkg-reconfigure gdm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.