I have just upgraded the kernel on my 64-bit Ubuntu 13.04 to 3.8.0-22-generic. Now my unity panel, dash and launcher are missing and graphics are running really slowly. Compiz and openGL seem to be failing. I've tried reinstalling Catalyst 13.4 but that does not fix it. I also tried these commands:

dconf reset -f /org/compiz/
unity --reset-icons &disown

This happened once before and I think the above commands worked, but I'm not having and success this time.

The last command gives these errors:

[1] 2616
compiz (core) - Info: Loading plugin: core
compiz (core) - Info: Starting plugin: core
unity-panel-service: no process found
compiz (core) - Error: Another window manager is already running on screen: 0
compiz (core) - Info: Stopping plugin: core
compiz (core) - Info: Unloading plugin: core
unity --reset-ico (process:2656): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

Please help!

UPDATE 1:30pm EST 25 May 2013: Well today I just started up as normal and everything is working; my launcher icons reset to default, which I am guessing was the result of the second command above. Weird. Florian, here is the output of the two commands you asked me to run (now after it seems to be working):

$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string:   ATI Technologies Inc.
OpenGL renderer string: AMD Radeon HD 6670
OpenGL version string:  4.2.12217 Compatibility Profile Context 12.104

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes


$ sudo -- lshw -C display
   description: VGA compatible controller
   product: Turks XT [Radeon HD 6670]
   vendor: Advanced Micro Devices [AMD] nee ATI
   physical id: 0
   bus info: pci@0000:03:00.0
   version: 00
   width: 64 bits
   clock: 33MHz
   capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
   configuration: driver=fglrx_pci latency=0
   resources: irq:54 memory:d0000000-dfffffff memory:fe9e0000-fe9fffff ioport:e000(size=256) memory:fe9c0000-fe9dffff

UPDATE 1 June 2013: I had the same problem today after upgrading to kernel 3.8.0-23-generic and was able to get things back by running the first command only, then reinstalling AMD Catalyst 13.4 once again.

Is there any way to prevent having to do this with each kernel update? Is this an Ubuntu bug or an AMD Catalyst bug?

  • Please run /usr/lib/nux/unity_support_test -p and sudo -- lshw -C display in a Terminal and add the output of both commands to your question. – Florian Diesch May 25 '13 at 0:51

This worked for me. After messing around with getting the fglrx's installed and uninstalled from the Proprietary Drivers menu in gnome-control-center>software&updates, Unity was all gone and I just had the desktop (which had icons drawn on it, curiously). From that stage I ran sudo apt-get remove --purge fglrx*, and restarted. Still no Unity. I then called google-chrome & and downloaded the proper driver from http://support.amd.com/us/gpudownload/Pages/index.aspx. Then, as OP says, I ran dconf reset -f /org/compiz/ and a quick chmod +x driver_yadda_yadda.run and sudo ./driver_yadda_yadda.run, and it took me through the steps. After the prompted Install, everything is back to normal.


What has worked best for me so far is to simply jump into tty1 with Ctrl+Alt+F1 and then reinstall fglrx.

For the stable version in the Ubuntu repositories:

sudo apt-get install --reinstall fglrx fglrx-amdcccle

Or if you installed the updates version of AMD Catalyst:

sudo apt-get remove --purge fglrx-updates fglrx-amdcccle-updates

If you installed manually from a file downloaded from AMD, then navigate to your downloads folder and run the install file again:

cd ~/Downloads
sh amd-driver-installer-catalyst-13-4-x86.x86_64.run --buildpkg Ubuntu/raring

You will need to change "raring" to precise, saucy, trusty, etc. if you have a different version of Ubuntu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.