I know this is a dejavu but let me please explain my problem.
When booting 13.04 installation media EFI mode get to a black screen with Grub version 2.00-l3ubuntu3 version appears after selecting "install" or "try Ubuntu", there appear error messages:
- failure reading sector ... from 'cd0'
- you need to load the kernel first

  1. I have a Dell Vostro 3560 with Windows 8.
  2. I have downloaded and burned ubuntu-13.04-desktop-amd64.iso. Hashes checked.
  3. I've booted from the dvd with Secure Boot enabled.
  4. The same happens when Secure Boot is disable.
  5. When booting with Legacy BIOS, installation starts.

I tried Ubuntu without installing and looks OK. BUT, I did not follow the installation because in https://help.ubuntu.com/community/UEFI#Converting_Ubuntu_into_EFI_mode there appears "if the other systems (Windows Vista/7/8, GNU/Linux...) of your computer are installed in EFI mode, then you must install Ubuntu in EFI mode too.", which is the case in my computer.

I have read many similar questions and the corresponding answers from people in this forum, but till now I haven't found a solution.

Could someone help me on this subject?

Thanks in advance!

  • Possible duplicate of askubuntu.com/q/208405 and askubuntu.com/q/298819/102029 – geezanansa Jun 1 '13 at 14:48
  • So that means there is at least three questions asking the same specific thing and yet nobody gets the gist? - yet... – geezanansa Jun 1 '13 at 14:59
  • It could because your U/EFI firmware specification is EFI 1.1 which is purely Intel's work and not the collaborated UEFI versions. This may mean your firmware has been hard coded to favour microsoft efi boot loader/manager and can not see the vmlinuz files Ubuntu is trying to use!? To confirm which U/EFI specification your hardware uses just drop to grub command line (press "c" at the black and white grub screen you describe in question) after booting U/EFI mode and run lsefisystab to show information regarding your U/EFI specification. – geezanansa Jun 1 '13 at 15:19
  • Is it possible - that it is necessary to delete the recovery partition for to install dual-boot ? ( after disabling uefi in bios and enabling efi in bios ? ) – dschinn1001 Jun 19 '13 at 8:37
  • running boot-repair to install grub-efi after installing using legacy/bios mode does not resolve the issue of being unable to boot installation media using UEFI mode. This is necessary to repair grub-efi or using efibootmgr to fix/edit bootloaders on an uefi based system (using boot-repair, grub 2 disc, Ubuntu installation media or Parted Magic) How to resolve "you need to load kernel first" when booting any media using UEFI????? – geezanansa Aug 13 '13 at 20:46

I tried the Ubuntu Studio as well as Ubuntu - both fail to start in UEFI mode using the Live DVD image.

One of the workarounds (I haven't done this yet myself) is to install Ubuntu in BIOS mode using a separate dedicated boot partition on your GPT partitioned disk, not update any packages during installation or thereafter until you have replaced grub and installing grub onto your /boot partition, not onto MBR (e.g., not on /dev/sda, but on /dev/sda5 if /dev/sda5 is your /boot). Then boot again from the Live DVD and in the Live DVD run, install grub-efi replacing grub-pc. Then mount your installed Ubuntu's /boot onto the Live DVD's /boot: sudo mount -t ext4 /dev/sdaX /boot where /dev/sdaX is the installed Ubuntu's boot partition, e.g., sudo mount -t ext4 /dev/sda5 /boot - this assumes you have formatted /boot using ext4. Then install your UEFI System partition (ESP) onto /boot/efi, like so: sudo mkdir -p /boot/efi/ && sudo mount -t vfat /dev/sdaY /boot/efi/, e.g., sudo mkdir -p /boot/efi/ && sudo mount -t vfat /dev/sda2/ /boot/efi. Here it is assumed your /dev/sdaY was created by Windows 8 installation and uses the FAT32 filesystem. After this, install grub again: sudo grub-install. That I hope will place grub onto your /boot/efi/EFI/ubuntu/ directory. You may have to create a text file in your installed Linux's /boot partition containing some details for grub to find your / partition, named refind_linux.conf and containing:

"Boot using standard options" "root=UUID=17c62fb9-a67a-4bae-97d7-3b71e5d3c8ce ro   quiet splash $vt_handoff"
"Boot using minimal options"  "root=UUID=17c62fb9-a67a-4bae-97d7-3b71e5d3c8ce ro"
"Boot using recovery options" "root=UUID=17c62fb9-a67a-4bae-97d7-3b71e5d3c8ce ro recovery nomodeset"

Please refer http://www.rodsbooks.com/ubuntu-efi/ for more details on refind_linux.conf. Please find UUID for your / partition using blkid and replace appropriately.

Once this much is done, install rEFInd (http://www.rodsbooks.com/refind/index.html) and then reboot in UEFI mode, choosing rEFInd from your motherboard boot selection menu if needed. rEFInd should give you the option to boot your grubx64 image and that in turn should boot the Linux. I choose the manual install using Windows method mentioned on the page at link in this para.

rEFInd should boot your BIOS grub if you did not choose to replace it with grub-efi as well, but it did not work in my case (Ubuntu kernel would immediately panic after booting up, perhaps due to some quirk to do with my mainboard, a DH55TC (Intel) or with Ubuntu or with some hardware on my machine (wifi card I think), I don't know).

Also, the manner I've highlighted above doesn't mount your / partition from the installed Ubuntu when you run the live DVD. I don't know if this can materially affect the Ubuntu EFI's booting up of your installed Ubuntu.

I've to play with this myself, haven't done so yet.

But, ideally, I don't even want to go down this route. I hate the fact that Ubuntu is not able to boot up in UEFI mode from the Live DVD. I would rather install in UEFI mode directly instead of having to do the above, even if the above works (it is untested and might result in problems which I've not foreseen).

So, I'd suggest you try doing the same, perhaps by trying to install Ubuntu via flash drive in UEFI mode and see if Ubuntu is able to cleanly boot/install in UEFI mode then.

Or, switch to a distribution which can do this without having to resort to any fixes later; when I was browsing the web yesterday, I came across a reference which suggested OpenSuse does that cleanly (install in UEFI mode).

Edit: I have done the above myself now, see details below I have now tried certain steps and can outline what works for me.

  • Install Windows 8 in UEFI mode. My BIOS does NOT have secure boot, but I wanted to install Windows 8 in UEFI mode anyway and wanted to do away with MBR mode. Since Windows 8 works with GPT disks in UEFI mode, Windows partitioned my disk using GPT mode. I have 4 partitions after Windows install, all created by Windows: Recovery, ESP, Microsoft Reserved and Windows main.
  • Install Ubuntu 13.04 in BIOS mode (since it fails to boot/install in UEFI mode). The boot partition is a dedicated partition. I have Linux swap and / besides /boot and those partitions are encrypted, so have to create an unencrypted /boot separately. I install bootloader on the same partition as my /boot partition, not on the MBR, e.g., on /dev/sda5, not on /dev/sda.
  • After installation finishes, I reboot using UEFI mode into Windows and install rEFInd using manual installation method for Windows outlined on its website.
  • I reboot in BIOS mode, to Boot Repair CD. I do NOT carry out any repair (it messed up my partitions once earlier upon detecting both /boot and efi and chose to repair my partitions such that Windows didn't boot after that. What I do (after quitting boot repair dialog box upon boot up AND after having established an internet connection) is to drop to a terminal window and type:

    sudo apt-get install grub-efi

The above may or may not complete successfully, but I have sufficient components to be able to run a grub-install. Before running that, I mount Ubuntu's /boot partition to the running Boot Repair's /boot and then the esp to /boot/efi. Then I run

sudo grub-install

The above may attempt to install grub on all partitions, so you are forewarned.

Anyway, as a result, I now have /boot/efi/ubuntu with grubx64.efi in it and other files needed by grub in /boot. I also create the refind_linux.conf file in /boot as noted in my post and put the correct UUID for the installed Linux's / partition in it.

  • I reboot to rEFInd in UEFI mode (I no longer need to boot in BIOS mode and BIOS mode boot won't work to boot the installed Linux now). rEFInd shows me the option to boot my Linux by way of a Penguin icon (result of scanning for Linux kernels) and by way of Ubuntu icon (the grubx64.efi that I just installed through Boot Repair disk). I choose the grubx64.efi method (Ubuntu icon) since the other one doesn't work for me.

  • Whew. We are mostly done. Once booted into the installed Ubuntu (I installed Ubuntu Studio, not Ubuntu to be precise), before performing any package updates, I install grub-efi (since the installed Ubuntu only knows about the grub-pc until this point because I installed grub-efi externally using Boot Repair's disk, so that install is not proper or complete, it was just a hack to be able to boot to Ubuntu 13.04).

  • Then I mount the esp whilst running Ubuntu and modify the refind.conf to comment out the scanning option for all linux kernels, so that the Penguin icons are not shown any more (only the grubx64.efi's Ubuntu icon is shown) on the rEFInd menu. I do not want many icons covering each individual kernel installed in Ubuntu, on rEFInd menu.

Now, when I want to boot Linux, I just boot to rEFInd menu and choose the Ubuntu icon, otherwise I choose the Windows icon.

This setup is stable for me.


I experienced a similar problem installing on a new notebook. Perhaps this howto will help you, especially the part about "boot-repair" and some links at the bottom.

How to install a dual boot system on Medion Akoya P7816(MD 99076) with UEFI BIOS and Windows 8 pre-installed.

I bought myself a Medion Akoya P7816 (MD 99076) in The Netherlands from an Aldi supermarket and wanted to install Ubuntu 12.04 LTS (Zorin-OS 6.3), either as a primary system or as a dualboot system. The main problem I encountered was how to let the notebook start up from the DVD/CD-rom drive to access the live-cd, because this notebook has UEFI BIOS.

This is what I did and how it worked for me.

  1. Make free space on the hard disk from within Windows 8
  2. Adjust BIOS, so the notebook will boot from the DVD/CD-rom
  3. Start Ubuntu (Zorin 6.3) live-DVD and install Ubuntu on hard disk
  4. Start live-DVD again and run boot-repair (and recommended repair)
  5. Reset BIOS to have a working system again

1. Make free space on the hard disk from within Windows 8

Run compmgmt.msc on Windows 8 through accessing the Powershell as administrator in a terminal. From there on, create a partition with enough size. There a reports that state that, creating the partition from the live-dvd or live-usb, rendered Windows 8 unbootable, even after doing a boot repair. So to remove that problem or having a greater chance of removing it and making sure both systems work, partition your hard drive from within Windows 8 first. I didn't try removing Windows altogether, but you can consider doing this. In fact, why install Windows in a world without walls? So, you could try shrinking and moving the Windows-partitions with Gparted on the live-dvd after you have completed step 2.

2. Adjust UEFI BIOS

Access BIOS on start-up by pressing F2. In “Advance” change SATA configuration from AHCI to IDE In “Security” disable Secure Boot Management, In “Boot” enable “Launch CSM” (Compatibility Support Module), and check that Fast boot is disabled Press F10 and restart BIOS Access BIOS again through F2 Check that CSM and the other changes you have made, are still enabled as above. Now you should be able to set the boot order and put DVD/CD-rom (CDD) as first option in “Boot”. It looks as if this option is also available under “Advance”, but you don't have to change it there. Put in the live-DVD (I used Zorin-OS 6.3 64bit, but Ubuntu 12.10 64bit or higher should do the job as well) Press F10 and restart

3. Start live-DVD and install Ubuntu (64bit 12.10 or higher or Zorin-OS 6.3)

Install Ubuntu as you are used to. It is required to make a small partition of about 25 MB that is reserved for bios_grub. Should you forget to do this, Ubuntu will warn you. It is also mentioned that you have to create a partition with mount-point /boot/efi. You could skip this part. In case of trouble, make the partition, just to be sure. I always use the advanced options on installation and make the following partitions in the free space on the harddisk (that I have previously created via Windows 8 or via Gparted bij starting the live-DVD first): partition of 25 MB reserved for bios_grub partition of 100 MB with mount point /boot/efi and formatted als fat32 (dispensable?) root partition of 50 GB with mount point / and formatted as ext4 swap partition of 2GB home partition for the remaining space and with mount point /home and formatted as ext4

Install Ubuntu as you are used to and shut down as required by opening the DVD-drive, (don't remove the live-DVD completely).

4. Start live-DVD again and run boot-repair

After shutting down, press in the DVD-drive and restart again from the live-DVD, without changing anything to your BIOS at this point. Start up from the live-DVD and run boot-repair in a terminal. Some documentation mentions that you can access the newly installed Ubuntu-OS. However, that didn't work for me, because my notebook didn't start any OS at this point because of the changes I made in BIOS. So, start the live-DVD again.

Open a terminal and copy-paste the following commands in the terminal and follow the instructions.

 sudo add-apt-repository ppa:yannubuntu/boot-repair  
 sudo apt-get update
 sudo apt-get install boot-repair

Now run boot-repair from the terminal

Remember to keep Grub 2 by answering 'No' to the prompt message. You will have to open a second terminal in the process. Do this and copy-paste the commands that you receive. Boot Repair will mention that we have some GRUB error and that we have an EFI system. Just click on Apply so boot repair fixes everything.

Now shut down the live-DVD and go to the next stage.

5. Reset BIOS to have a working system again

Now you have to reset most of the BIOS to be able to access the Grub-menu you are used to on a dual boot system. Access BIOS on start-up by pressing F2. In “Advance” change SATA from IDE to AHCI (not necessary for the system to work) In “Security” keep Secure Boot Management disabled In “Boot” enable Fast boot (not necessary, but your notebook will start a little quicker and Grub will show in a nice large screen on start-up. The downside is that you don't see the Medion start-up screen during future start-ups and you have to be quick to press F2 when you want to access BIOS In “Boot” disable “Launch CSM”again. Press F10 and restart BIOS Access BIOS again through F2 In “Boot” check that Launch CSM is disabled and the other resets you have changed as mentioned above are still as they should be right now. Now you should be able to reset the Boot Option 1 to 'Windows Boot Managemer' as well. Press F10 and restart

Now you should see Grub and be able to dual boot your system.

Other documentation and sources on this subject in order of usefulness:

  • An excellent answer, great research and well explained! – Oyibo May 31 '13 at 8:52
  • Shame it does not answer the question though; "How to fix "need to load kernel first" error in order to boot installation media U/EFI mode?". At least that is the way i see the question that is being asked.! Nice workaround though. – geezanansa Jun 1 '13 at 14:53
  • Section 5 refers to Secure Boot inaccurately considering this example has clearly stated windows 8 came pre-installed. Windows 8 WILL USE SECURE BOOT on machines that have it pre-installed before leaving factory. This is criteria for any machine that wants to use windows 8 accreditation. Using Ubuntu >= 12.04.2 will allow installation with Secure Boot enabled. – geezanansa Jun 1 '13 at 18:36
  • (Posted By @jswinner )This worked for Toshiba s855 with boot repair. Secure boot did not work on this newer model. Great write up. – BiggJJ Jun 30 '13 at 3:16

protected by Community Aug 13 '13 at 18:03

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.