6

I installed Ubuntu 13.04 x64-amd on my Acer Aspire v3-471G laptop. The touchpad wasn`t working since I started the installation process from a USB flash device using Pen Drive and continue to be not functional after successful installation. I updated the system but nothing got it worked.

Using command xinput list to list the available connected device, it shows the following

Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Genius 2.4G Wireless Mouse                id=12   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=14   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ HD WebCam                                 id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]
    ↳ Acer WMI hotkeys                          id=15   [slave  keyboard (3)]

I couldn`t find any solution online. I appreciate any help here :)

  • 1
    I had a similar problem I created a bootable 13.04 usb stick using unetbootin and after a successful install. I then rebooted and I had no keyboard no mouse on start-up, or my system would not boot at all and it would get stuck on booting the usb drivers. I re-made a new bootable usb directly in ubuntu following these instructions and reinstalled and everything worked. ubuntu.com/download/desktop/create-a-usb-stick-on-ubuntu Old versions of unetbootin may not be copying files over again – Rick T Jun 12 '13 at 14:44
1

Yahya's solution worked. But with one extra step. I went to BIOS, set touchpad to basic.

At first it did not work but when I activated the toucpad using FN+F7, it started to work.

0

I think the problem is of during installation.Use universal usb installer instead. It works like a charm for me and even recommended by Ubuntu's official USB mouting guide.

Below is the link for it: http://www.pendrivelinux.com/universal-usb-installer-easy-as-1-2-3/

0

The chances are that you have already found a solution. But just in case... My laptop is the same make and I faced exactly the same problem (along with inactive brightness keys and overheating).

This solution for the touchpad issue was not my creation. But here it is...

    cd /etc/modprobe.d/

    sudo gedit options.conf 

In the text editor, type: options psmouse proto=imps

Save the file and close it.

    sudo modprobe -r psmouse 

    sudo modprobe psmouse 

I do hope the solution works for you. It worked like magic for me. (Would have shared the link with you, but don't seem to have it).

I thank the people who authored this and the other solutions that makes ubuntu run in acer aspire v3-471g.

  • I am on Ubuntu 16.04 now and there exists no file /etc/modprobe.d/options.conf. I guess this solution is outdated. – XavierStuvw Sep 13 '16 at 6:35
0

I just solved it by changing touchpad from advanced to basic in main tab of bios settings. You can access to BIOS by turning off laptop, and then turn it on again and press f2 after ACER logo showed up.

0

In my case 'xinput list' did not contain the touchpad, and the following method got the touchpad working again: https://unix.stackexchange.com/a/244895

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy