installing the driver for the Huawei Vodafone K3772 key in Ubu 13.04 I get the following error:

"make: *** [install] Errore 2
Install NDIS driver failed.
The compiling environment is not all ready.
Please check gcc, make and kernel buid(/lib/modules/3.8.0-22-generic/build) to be all installed?
Now please enter any key to finish other installations.
NDIS is disabled, and only Modem can be used".
These packages gcc, make, and others are installed.

I have another laptop with Mint 14 KDE and the installation is successful ane the key work fine. What can miss on 13.04 to finish the installation from source?


  • Have you installed build-essential? – Manuel May 24 '13 at 14:10
  • I get the same error! – Naveen Jul 6 '13 at 15:32

Download the modified driver from this link.


  • Extract the archive to Desktop
    $ cd ~/Desktop
    $ tar -xvf Linux\ Driver\\(Modified\).tar.gz
  • Change to the extracted directory whose name is driver
    $ cd driver
  • Switch to root and make the script named install executable
    $ su
    $ chmod +x install
  • Install the script
    $ ./install
  • The NDIS driver installation failed error will not occur. Instead it will show NDIS driver installation successful.

Creating a Mobile Broadband connection

  • Go to Settings -> Network -> Mobile Broadband and click Add new connection
  • Follow the steps which involves selecting the country, operator etc.

Next time if you insert the modem it will be detected properly and you can connect to the Mobile Broadband connection you created previously by clicking the Network icon on the system tray.

| improve this answer | |
  • Its working in Ubuntu 14.04 with Huawei E173 3G Modem. – Gobinath Oct 13 '15 at 13:29

I found same issue, and could modify. Please try a below patch.

diff -ru driver_org/ndis_driver/ndis_src/src/hw_cdc_driver.c driver/ndis_driver/ndis_src/src/hw_cdc_driver.c
--- driver_org/ndis_driver/ndis_src/src/hw_cdc_driver.c 2012-06-13 21:13:08.000000000 +0900
+++ driver/ndis_driver/ndis_src/src/hw_cdc_driver.c     2013-05-25 03:18:23.335755961 +0900
@@ -2715,7 +2715,7 @@
     // set up our own records
     net = alloc_etherdev(sizeof(*dev));
     if (!net) {
-        dbg ("can't kmalloc dev");
+//      dbg ("can't kmalloc dev");
         goto out;


| improve this answer | |
  • 1
    after several attempts and after reinstallig usb_modeswitch, I managed to connect the key in an appropriate way and with the maximum connection speed.I configured usb_modeswitch manually by following the instructions found on the site draisberghof.de/usb_modeswitch/device_reference.txt. I do not know why it is so complicated to install a usb stick in linux! – Fabio May 26 '13 at 12:10
  • Please how do you apply the patch? – user179723 Jul 30 '13 at 9:03
  • see the post askubuntu.com/questions/323031/… for NDIS driver problem – Avinash Raj Oct 30 '13 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.