31

Chrome in Ubuntu is not rendering Urdu fonts properly. It is showing gibberish characters I'm not able to read. The problem is especially bad on Facebook.

I copied some Urdu fonts under ~/.fonts and under /usr/share/fonts/ and updated the cache and then restarted Chrome but even that didn't work.

This is how it is appearing on my system

text

I have installed MSCore fonts and many other fonts but it's still not working.

9 Answers 9

24

Download and install nafees-urdu fonts.

Update the package index:

sudo apt-get update

Install the fonts-nafees package:

sudo apt-get install fonts-nafees

and refresh your browser. This works fine for me.

or try this: http://www.urdujahan.com/linux.html

6
  • You mean restart your browser? Aug 21, 2019 at 9:43
  • No need just refresh the page, that should work
    – smali
    Aug 21, 2019 at 12:28
  • 2
    Didn't work. I had to restart my browser. Using Ubuntu 18.04. Aug 21, 2019 at 12:51
  • 3
    Negative. Didnt work in 20.04. imgur.com/a/drvdTV4
    – Tahir
    May 3, 2020 at 19:51
  • go to chrome://settings/fonts and select nafees font there
    – Hammad
    Jun 5 at 17:16
8

I installed fonts-noto

$ sudo apt-get -y install fonts-noto

Restarted Chrome, and then changed the Standard Font in Chrome to Noto Naskh Arabic UI. Urdu fonts appear much better and clear now. You can find the 'Font Settings' at: chrome://settings/fonts Font Preview Chrome Settings Preview

Update (for Firefox): You can change the fonts settings to Noto Sans Arabic UI in Firefox preferences Under Langugage and Appearance section

You can use this Chrome extension as well: https://chrome.google.com/webstore/detail/nastaleeq/oddbjmjgpaofommagnbfednbdifaakfb?hl=en

5
  • 1
    This is the best solution.
    – dmSherazi
    Jun 23, 2019 at 6:01
  • This solution is Chrome specific. Can you suggest something for Firefox? Yes, on Chrome, it solved the problem.
    – Tahir
    May 16, 2020 at 19:00
  • @TahirAkram Have you tried changing the Preferences -> Language and Appearance -> Fonts and Colors -> Default Color to Noto Sans Arabic UI?
    – Junaid
    May 18, 2020 at 11:20
  • Any ideas how to apply this solution to the WhatsApp desktop client on Linux Mint? It's an Electron app. Dec 7, 2020 at 1:44
  • Haven't tried that. Did you look into changing system font to Noto Sans Arabic UI by using any font-tweak tool?
    – Junaid
    Dec 7, 2020 at 11:09
2

What worked for me was was to go to

Menu → language settings

and install "full support for urdu language".

Then, in the Firefox browser, go to

Preferences → General → Language → Choose your preferred language for displaying pages

and change Latin to nafees.

1
  • This changed the default language of the browser but it will not change the font style. Oct 25, 2020 at 19:14
1

Install tahoma fonts or install from your windows fonts directory /windows/Fonts

Install following chrome extension.

Font Changer With Google Fonts

Go to twitter or facebook or any other site and left click the extension. Use custom settings and select tahoma. Click ok and then refresh the page.

1
  • 2
    Some other fonts also works like segoe UI, you can add them in extension custom fonts settings. you can also add urdu fonts like jameel noori nastaleeq in custom fonts.
    – wedu
    Jan 30, 2014 at 10:47
1

I think the problem is that Ubuntu does not have unicode Arial fonts. I just found a solution that is working well on Facebook .

First you need to install 'nafees fonts' for Ubuntu.

  1. Get the Chrome extension "change font family style" from Chrome store.
  2. Go to its settings, in tools > extensions
  3. Go to the extension's option.
  4. Paste this 'lucida grande',tahoma,verdana,nafees,sans-serif
  5. Click save, then close the window, and refresh the facebook page. it should work.
1
  • 1
    4. Where should I paste it I didn't understand? Oct 25, 2020 at 19:09
1

Guys I also had this issue and fixed with chrome extension Nastaleeq.

Kubuntu 19.04 x64 Chrome Version: 77.0.3865.90 (Official Build) (64-bit)

1

Just go to chrome settings and search for customize fonts and change standard font to Nafees. No need to install anything.

2
  • Younus, it didn't work in Chrome. This is the screenshot. imgur.com/a/2KgSWTf I selected Nafees as standard font. Can you suggest the same for Firefox?
    – Tahir
    May 16, 2020 at 19:18
  • Not any experience with firefox about that. May 17, 2020 at 7:12
0

Another Chrome extension that gave me better results is: Wudooh. After installation, you can select Noto Nastaliq Urdu from the drop-down menu. You also have the options for adjusting the font size as well as line height.

0

I have tried many methods but not working I have solved the problem via install in chrome web store this extension name is "nastaleeq" after installing nastaleeq restart your chrome browser Enjoy!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.