Chrome in Ubuntu is not rendering Urdu fonts properly. It is showing gibberish characters I'm not able to read. The problem is especially bad on Facebook.

I copied some Urdu fonts under ~/.fonts and under /usr/share/fonts/ and updated the cache and then restarted Chrome but even that didn't work.

This is how it is appearing on my system


I have installed MSCore fonts and many other fonts but it's still not working.


Download and install nafees-urdu fonts.

Update the package index:

sudo apt-get update

Install the fonts-nafees package:

sudo apt-get install fonts-nafees

and refresh your browser. This works fine for me.

or try this: http://www.urdujahan.com/linux.html

  • You mean restart your browser? – Mr.Shan0 Aug 21 at 9:43
  • No need just refresh the page, that should work – Ali786 Aug 21 at 12:28
  • 1
    Didn't work. I had to restart my browser. Using Ubuntu 18.04. – Mr.Shan0 Aug 21 at 12:51

I installed fonts-noto

$ sudo apt-get -y install fonts-noto

Restarted Chrome, and then changed the Standard Font in Chrome to Noto Naskh Arabic UI. Urdu fonts appear much better and clear now. You can find the 'Font Settings' at: chrome://settings/fonts Font Preview Chrome Settings Preview

  • 1
    This is the best solution. – dmSherazi Jun 23 at 6:01

What worked for me was was to go to

Menu → language settings

and install "full support for urdu language".

Then, in the Firefox browser, go to

Preferences → General → Language → Choose your preferred language for displaying pages

and change Latin to nafees.


Install tahoma fonts or install from your windows fonts directory /windows/Fonts

Install following chrome extension.

Font Changer With Google Fonts

Go to twitter or facebook or any other site and left click the extension. Use custom settings and select tahoma. Click ok and then refresh the page.

  • 2
    Some other fonts also works like segoe UI, you can add them in extension custom fonts settings. you can also add urdu fonts like jameel noori nastaleeq in custom fonts. – wedu Jan 30 '14 at 10:47

I think the problem is that Ubuntu does not have unicode Arial fonts. I just found a solution that is working well on Facebook .

First you need to install 'nafees fonts' for Ubuntu.

  1. Get the Chrome extension "change font family style" from Chrome store.
  2. Go to its settings, in tools > extensions
  3. Go to the extension's option.
  4. Paste this 'lucida grande',tahoma,verdana,nafees,sans-serif
  5. Click save, then close the window, and refresh the facebook page. it should work.

Guys I also had this issue and fixed with chrome extension Nastaleeq.

Kubuntu 19.04 x64 Chrome Version: 77.0.3865.90 (Official Build) (64-bit)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.