Specifically I am trying to use the workspace switching shortcut Ctrl+Alt+. They work fine when I press Alt then Ctrl then an Arrow key, but not when I do Ctrl then Alt. This behavior even carries over for the Ctrl+Alt+Shift+Arrow commands for moving windows between workspaces. I am certain this behavior was not always so. How can I get back to the usual Ctrl/Alt order invariance?

Ubuntu 12.10 64-bit.

EDIT: Turns out this only happens when the Num Lock key is on. I have no reason to ever have Num Lock off, so I would really like to understand why Num Lock is somehow changing my Ctrl+Alt behavior.

EDIT 2: This only happens with the left alt key.

  • 1
    While I can't answer your question, I can give some potential answerer's some food for thought. This a very odd behavior. Ctrl and Alt are modifier keys, so it shouldn't matter what order they're pressed in as long as they are both depressed when hitting an arrow key. Sounds like this might be an xkbd issue? – Chuck R May 24 '13 at 6:27
  • Do you have another keyboard (different brand/type) to confirm this is a software issue? – gertvdijk May 29 '13 at 8:51
  • I tried using the OnBoard virtual keyboard and it worked properly, however it only has one ctrl and one alt key, so I'm not sure it's a good test of an issue that specifically occurs with left-alt. I don't have easy access to another keyboard I can test with. – Noah May 30 '13 at 2:45
  • @gertvdijk it's definitely not a hardware problem. I can go into a guest session and everything works fine. I just need to figure out what I need to reset. I'm not particularly attached to any configuration settings I have right now, so if I can just rm -rf something somewhere I'd be happy. – Noah May 30 '13 at 20:09
  • @Githlar, if this is an xkbd issue, how might I go about confirming/addressing it? – Noah Jun 1 '13 at 9:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.