enter image description here

And http://webglreport.com/

enter image description here

 google-chrome --version
 Google Chrome 27.0.1453.93 


enter image description here

How To Enable WebGL In Chrome On Ubuntu ?

7 Answers 7


For WebGL to work in Google Chrome (and Chromium), Here are the steps to enable WebGL in Google Chrome.

Step 1: Open Google Chrome

Step 2: Type chrome://flags in the address bar

Step 3: Press Ctrl + f and type ” Rendering list “, “Override software rendering list” should come up, Now click on Enable and restart the browser.

Step 4: Completely kill Chrome: Type killall chrome into a console.

Step 5: Go to chrome://settings and enable Use hardware acceleration when available. By default it is off since version 43.

Step 6: Start Chrome

enter image description here

Now check chrome://gpu/

enter image description here


enter image description here


  • 3
    Now I have YouTube in HTML5 players with nice performance! Nov 9, 2013 at 19:01
  • 19
    Why is this not enabled by default??? Dec 20, 2013 at 4:00
  • 4
    Hint: in Ubuntu for sure (windows also most likely) you will need to be sure to kill the background threads (chrome) as well before the changes will take effect. Jan 21, 2014 at 14:15
  • 1
    @Kostanos no i do not know abot that...thats the easiest way ...
    – Qasim
    Apr 30, 2014 at 4:48
  • 1
    for some reason this does not help me to enable webgl in Chrome 37.0.2062.94 (64-bit) under ubuntu *(
    – SET
    Aug 29, 2014 at 19:27

If you still don't get any results, check if hardware-acceleration is enabled in Chromium settings, Google tends to disable this setting by default since version 43. In this case that was the problem for me after I updated GPU drivers, overrode the GPU blacklist, and so and so.

  • 4
    Same here. I thought I was seeing some terrible bug but didn't realize chrome://settings -> Show advanced settings... -> Use hardware acceleration when available somehow got disabled. I flipped it on, restarted the browser, and everything works. Jul 12, 2015 at 6:13
  • Disabling hardware-acceleration worked for me. Jun 4, 2017 at 11:33

Maybe too old your video driver or not installed properly.

I had same problem too, but this solution fixed my problem without overrides!

  1. To add PPA for Ubuntu 14.04 / 13.10 / 13.04 / 12.10

    Ubuntu 14.04 / 13.10 / 13.04 / 12.10 users, Run the following command in the terminal and type the password for the user when prompted. Others use the Ubuntu-X PPA.

    sudo apt-add-repository ppa:xorg-edgers/ppa
  2. To add PPA for Ubuntu 12.04 / 11.10 / 11.04 / 10.04

    sudo apt-add-repository ppa:ubuntu-x-swat/x-updates

    After adding the PPA, update your system repository.

  3. To Update

    sudo apt-get update

    Now install the NVIDIA GeForce graphics driver 304.108 in your system, as you install other packages by using apt-get.

  4. To Install

    sudo apt-get install nvidia-current nvidia-settings

    Above command will install the driver.

Source: http://www.howopensource.com/2012/10/install-nvidia-geforce-driver-in-ubuntu-12-10-12-04-using-ppa/

  • I's using this solution on my desktop for a week, but my Chrome sometimes eat all CPU (the "GPU process" task). - I have Ubuntu Trusty with "GeForce 8400 GS Rev. 2" - I can not found solution for this side effect, only I have a workaround: Turn on "Disable accelerated 2D canvas" option in chrome://flags/ ... Grrr
    – andras.tim
    Oct 30, 2014 at 19:27

using chromium Version 49.0.2623.108 on Ubuntu 14.04 (64-bit).

What we need to activate is #ignore-gpu-blacklist

It's the first line in chrome://flags/

Hope it can help,


I had the issue that WebGL was reported as unavailable after switching from the proprietary Nvidia to the nouveau drivers, a change which does not seem to have been picked up in the chromium GPU config of my profile. The fix is running chromium-browser --single-process once to reset the GPU configuration.


If you have tried the things posted above and it is still not working, try using different drivers. Go to Software And Updates and there select Additional Drivers. Then select either the middle option or the last one (either Proprietary Binary or Nuveau). In my case I selected Proprietary Binary, but it got reverted to Nuveau and now I have WebGL enabled..


To have it working again I've had to upgrade mesa drivers.

What needed to be done on Pop!_OS 22.04 LTS in my case:

  1. In chrome://flags Override software rendering list -> ENABLED
  2. sudo add-apt-repository ppa:kisak/kisak-mesa to add the PPA
  3. sudo apt update && sudo apt full-upgrade to update and upgrade
  4. reboot
  5. Check that Use hardware acceleration when available is ENABLED in chrome://settings/system


  1. chrome://gpu
  2. https://webglreport.com/?v=2 - you should see Major Performance Caveat:No


  1. I'm on Pop!_OS 22.04 LTS
  2. using Chrome Version 120.0.6099.71 (Official Build) (64-bit)
  3. I've got Intel Corporation Iris Plus Graphics G4 (lspci| grep VGA)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .