8

I've recently upgraded my hardware to a new laptop, and installed the latest kubuntu build on the new machine. Various advice here and elsewhere led me to hope that I could bring all of my KDE settings over to the new machine by copying my home directory and .kde dir over to the new machine. I've done that, but it comes up with a mostly blank garbled screen with blue gibberish along the bottom instead of the menu bar - basically unusable in the graphical interface. Presumably this is because the old graphics settings aren't compatable with the new hardware (the monitors are the same, but the new machine has a new graphics card.)

I can log in to a command-line tty at Ctrl-Alt-F1. I'm looking for how to reset the display settings without losing (or with losing as little as possible of) my other settings; I imagine wiping my entire .kde directory would get me back, but I'm hoping for something less drastic. Any suggestions?

2

On my system (Precise), KDE's display settings seem to be stored in the file ~/.kde/share/config/krandrrc. It contains a section

[Display]
ApplyOnStartup=true
StartupCommands=xrandr --output LVDS1 --pos 0x400 --mode 1280x800 --refresh 60.0029\nxrandr --output DP1 --pos 1280x0 --mode 1920x1200 --refresh 59.9502\nxrandr --output LVDS1 --primary

that I assume tells KDE to apply those settings on startup.

Try renaming or deleting this file.

You could also try running sudo apt-get install lxde-core and then logging into an LXDE session. That will give you a graphical environment that you can run KDE's systemsettings from to make any changes you need.

  • Too bad, since I don't have krandrc on Kubuntu 14.04 LTS. – user2161065 Aug 12 '14 at 6:52
  • 1
    This answer seems to be obsolete – Jonathan Cast Jan 10 '17 at 15:00
33

I had to remove .local/share/kscreen on plasma5

  • 1
    Consider suggesting an edit to the accepted answer. – muru Dec 13 '15 at 17:03
  • 1
    On Kubuntu 16.10 it is the correct answer. – Rudy Vissers Jan 6 '17 at 9:23
  • also for netrunner – vivoconunxino Jan 12 '17 at 18:51
  • That worked also for me, even in 2019. Thanks. – Marcin Dec 19 '19 at 10:26
9

On Ubuntu 14.04:

1) Move away from X with ctrl+alt+f2

2) Login (as the user having this problem)

3) Type these:

cp -a ~/.kde/share/apps/kscreen ~/.kde/share/apps/kscreen.bak
rm -f ~/.kde/share/apps/kscreen/*
sudo reboot

First command is not mandatory.

  • 2
    Why not mv ~/.kde/share/apps/kscreen ~/.kde/share/apps/kscreen.bak && mkdir ~/.kde/share/apps/kscreen? – David Foerster Feb 5 '15 at 22:37
  • On kubuntu 16.06 it was ~/.local/share/kscreen and it worked. – xiawi Mar 20 '17 at 20:28
  • I know this is an old post, but on 18.04 this works. KDE messes up my 2 external monitor settings every now and again, the above works for me – avrono Sep 13 '18 at 8:50
1

assuming you have started your machine with X running (but not visible on any screen), you can do the following:

  1. Go to the console with Ctrl+F1 and log in
  2. Set your display variable export DISPLAY=:0
  3. Execute xrandr and check output
  4. Try to reactivate one of the connected displays with xrandr --output LVDS-0 --auto (where LVDS-0 is my built-in laptop display).
  5. Log out and switch back to X with Ctrl+F7. Now you can reset your display configuration as usual.

Good luck!

FAQ:

  • If xrandr gives you `Can't open display', then either you forgot to export DISPLAY variable, or your X-Server is not up and running

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.