How to "properly" downgrade LibreOffice versions deals with a downgrade from 3.5 to 3.4.*. Is there any way to nicely downgrade LibreOffice 4.0 to 3.6? The latter is not in the package lists.

Background: It is because of this bug which is about the incompatibility of an extension which should really be core functionality. Essentially, 4.0 just does not deal with templates in an intelligent way. You cannot fully apply a template to an existing document.

Update: based on apt-cache showpkg libreoffice (found on How to Downgrade a Package via apt-get?) one can confirm that only LibreOffice 4.* is in the repositories.

  • You could add this LO 3.6 repo and then proceed to ppa-purge the 4.0 repo. Haven't tried this out myself but it should work in principle. May 23, 2013 at 16:07
  • In the technical details it states that this is for quantal and precise. Will it work for raring as well or will it leave a mess behind?
    – don.joey
    May 23, 2013 at 16:10
  • I don't know, sorry. I am still on 12.04 May 23, 2013 at 16:12
  • @don.joey didn't work for me on raring - W: Failed to fetch http://ppa.launchpad.net/libreoffice/libreoffice-3-6/ubuntu/dists/raring/main/binary-amd64/Packages 404 Not Found => apt-cache only offers 4.0.2. Sep 17, 2013 at 1:34
  • 1
    @Braiam No the extension for which I wanted to do this has been merged. I am not sure which of these answers works.
    – don.joey
    Mar 30, 2014 at 18:32

3 Answers 3


For me this worked:

sudo apt-get install synaptic
sudo apt-get purge libreoffice*
sudo apt-get clean
sudo apt-get autoclean
sudo apt-get autoremove

Then remove ppa for LibreOffice4 Add ppa for LibreOffice3.6

sudo apt-get update

via synaptic reinstall packages which make problems for me it was libexttextcat

Install LibreOffice via synaptic.

  • Your suggestion worked for me. I downgraded from LibreOffice 4.4 to 4.2. However, I do not think Synaptic is necessary. I did all in terminal. I installed with: sudo apt-get install libreoffice and this worked fine for me. Thanks
    – jbrock
    May 4, 2015 at 22:02

There is a way to downgrade but not as "nicely" as I would like.

  1. Install Synaptic sudo apt-get install synaptic
  2. Uninstall libreoffice sudo apt-get purge libreoffice
  3. Add the Libreoffice 3.6 ppa sudo add-apt-repository ppa:libreoffice/libreoffice-3-6
  4. Refresh the repositories list sudo apt-get update
  5. Install LO 3.6 sudo apt-get install libreoffice=1:3.6.6-0ubuntu1~precise1~ppa1 . I never done this but there is information on how to install specific version here.
  6. Open Synaptic, search for Libreoffice, select the package and from the package menu select Lock version.

Hope this helps.

  • 1
    Thanks for the answer, I have just tried it but it doesn't work. Jul 25, 2013 at 16:04

Had this problem of downgrade too (from 4.1 to 4.0.4 ). Found this solution in a libroffice page & it's working fine!

If you have no menus on a Debian/Ubuntu-based system or trouble with the install, you likely didn’t uninstall the distro version of LibreOffice completely. You will need to make sure all the binary packages listed here: https://launchpad.net/ubuntu/+source/libreoffice are uninstalled. On Ubuntu releases, executing:

sudo apt-get purge libreoffice*  
sudo apt-get purge openoffice.org-dtd-officedocument1.0 python-uno python3-uno uno-libs3 ure

Source: https://wiki.documentfoundation.org/ReleaseNotes/4.1#Most_Annoying_Bugs

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .