1

I'm using kate on my ubuntu 13.04 unity without any problems. Even the dark mediterranean-themes (http://gnome-look.org/content/show.php/?content=156782) look great inside kate.

As you may see in the screenshots, this is a theme with dark background and bright foreground (some greyish-white). If I now start search/replace inside kate, the input text field has a dark background and bright foreground as expected from the theme. Depending on the matches, kate changes the background on-the-fly to some light green or light red, without altering the foreground color. This makes reading extremely difficult.

Is there a way to adjust the foreground color or disable this behavior? I already searched Fonts & Colors inside the configuration, but this menu entry seems to be restricted to the editor only. Any ideas?

1

There is the Gnome Color Chooser app that allows you to customize the desktop. Install by issuing the following command.

sudo apt-get install gnome-color-chooser

If will then show up in the System Tools | Preferences menu. Can also type gnome-color-chooser from terminal.

In the "Global Colors" tab there is a "Entry Field" section. I'd experiment by adjusting those colors to see if you get a better result.

0

In Mint 18 Cinnamon (Gnome)(Ubuntu based): Menu >> Preferences >> KDE System Settings >> Color >> Zion(reversed)

So you need to install KDE config apps for Ubuntu if they are not installed. "KDE System Settings" in Mint == "systemsettings5" command.

And then in Kate: Settings >> Configure Kate >> Fonts and Colors >> Default Schema for Kate Set to "KDE"

  • Welcome to AskUbuntu! This site is devoted to Ubuntu. Answers regarding Mint are welcome at our sister site unix.stackexchange.com – Elder Geek Jul 25 '18 at 21:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.