19

I would like to disable the function right-click when tapping the touchpad with two fingers, because it is always interfering with the two-fingers/scrolling function. I also would like to maintain the function left-click when double tapping with one finger. Thanks for the help.

22

Are you comfortable with the command prompt?

You can configure in detail how you want your touchpad to behave using synclient

You can get a list of current settings by doing synclient -l

For your specific request, you will need to run synclient TapButton2=0 to dissable the feature. To make the feature persistent create a ~/touchpad.sh configuration.

More info...

3
  • Mark question as answered then? Cheers. – conner_bw May 23 '13 at 18:08
  • 1
    Thank you! occasional righclicks while scrolling with two finger bothered me for a long time. – harry Jul 16 '13 at 4:15
  • Why isn'ter there a /etc/synclient.d/ like every other program? – Jonathan Dec 27 '14 at 21:05
5

To summarize most everything that everyone has said, just open a console and run the following three commands:

echo "synclient TapButton2=0" > ~/.touchpad.sh
chmod +x ~/.touchpad.sh
gsettings set org.gnome.settings-daemon.peripherals.input-devices hotplug-command “~/.touchpad.sh”
1
  • This worked until I logged out. I suppose the hotplug command wasn't working for some reason. – Jonathan Dec 27 '14 at 23:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.