When I click on a PDF link on Chromium I get a 'Missing Plug-in' page.

Missing Plug-in

It used to be that it would download the PDF and then I could view it with Evince. To do this now I have to right click and click 'Save Link As...'. How can I get this to happen when I click on the link?

This is what about:plugins looks like:


I am using Ubuntu 10.10 32bit with Chromium 9.0.597.107 (75357).

| improve this question | | | | |
  • This annoys the bejsus out of me. On Windows it just shows the pdf with a rather nice internal viewer. On Ubuntu, it complains that it might pose a security threat, are you sure you want to download it? And then saves it. – psusi Mar 11 '11 at 14:26
  • What's your Chrome Version number? (Wrench -> About Google Chrome) – Ward Muylaert Mar 11 '11 at 19:09
  • Chromium 9.0.597.107 (75357) Ubuntu 10.10 – dv3500ea Mar 11 '11 at 19:26
  • I am not 100% sure of this but are you using Ubuntu x86_64? This seems to be a problem with 64 bit systems with me. I have 1 i386 Ubuntu 10.10 ( Pinguy OS) and 1 x86_64 (Pinguy OS). On the 32bit system, chromium uses the mozplugger plugin (evince pdf reader) to view pdfs inside the browser with no problems while the same setting on my 64bit system says missing plugin. BTW, i dont have a solution for it yet except advise you to use firefox when viewing pdf. I will update soon. – Ubuntuser Mar 14 '11 at 18:40

This is no longer a problem - I am now using the version from the 11.04 repositories (Chromium 11). I assume this was a bug that was fixed. A solution for people on Ubuntu 10.10 who are having this problem would be to use a PPA to upgrade to a later stable release.

| improve this answer | | | | |


Problem is solved with new version Mozplugger. Actually in version "1.14.3". Chromium show PDF in browser. Like a PDF reader I'm using Okular.

| improve this answer | | | | |

To download PDF files automatically: pdf me extention works for me. it says "Convert any web page to a PDF file with one click" but after installing this extension when i click on pdf file it downloads automatically but it doesn't view the file online.

| improve this answer | | | | |

Go to the about:plugins page and pick Disable on "Chrome PDF Viewer".

enter image description here

If the entry isn't there, it might have to do with the plugin not being there at all in Chromium. This blog post explains how to add Google Chrome's PDF viewer to Chromium. Though that doesn't make it download automatically like you had before, it should at least look better than the missing plugin view.

| improve this answer | | | | |
  • I don't have a 'Chrome PDF Viewer' entry - see the screenshot I added to my question. – dv3500ea Mar 11 '11 at 18:19
  • @dv3500ea Added something that hopefully gives some progress at least. – Ward Muylaert Mar 11 '11 at 20:42

You can also check out this pdf viewer in javascript

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.