I'm using Ubuntu 12.04. I can connect to and use the internet on one wireless network (say A) and not on the other network (say B). I can connect to B and get an IP address.
When I ping it works When I ping it also works but when I ping I get destination host unreachable.

I tried commenting out dns=dnsmasq in /etc/NetworkManager/NetworkManager.conf but that didn't work and then restarting the network manager.

I also tried to flush the cache using ip route flush cache but that also did not work.

Any help would be appreciated.


closed as off-topic by jrg Aug 6 '14 at 14:41

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – jrg
If this question can be reworded to fit the rules in the help center, please edit the question.


The other network (network B) most probably has a firewall implemented, which is configured to block ICMP packets (pings). This is most likely the case if the network is in a university, at work, or maybe even a (smart) coffee shop.

When you ping, an IP should be mentioned in that message you got. I'm betting that that IP is, so the error would be something like reply: destination host unreachable. Also, to be more certain, you can do a traceroute. This shows you the path that your ping travels, so we can find exactly where it stops. So, if you run the command traceroute -n, you'll probably get something like this:

I think you might need to install traceroute using sudo apt-get install traceroute.

alaa@aa-UBUNTU:~$ traceroute -n
traceroute to (, 30 hops max, 60 byte packets
 1  1.204 ms  1.953 ms  2.101 ms
 2  * * *
 3  * * *

...and those stars will just keep on coming. This means that your ping went to, but then it stopped, it hit a wall, so you'll never be able to ping

Also, this has nothing to do with DNS, because you're pinging an IP, not a hostname like google.com. DNS is a system that merely translates the words google.com to something like If there was something wrong with your DNS settings, ping google.com would return something like this: ping: unknown host google.com, but ping would not, because you're already pinging a direct IP.

I suggest you revert the changes you made to NetworkManager.conf.

  • Hey Alaa I did do what you said. Here are the results: 'traceroute to (, 30 hops max, 60 byte packets 1 * * * 2 * * * 3 * * * 4 * * * 5 * * * 6 * * * 7 * * * 8 * * * 9 * * * 10 * * * 11 * * * 12 * * * 13 * * * 14 * * * 15 * * * 16 * * * 17 9.008 ms !N * * ' – canatan Jun 3 '13 at 2:55
  • Yes, this means that in network B, is blocking your pings, because it has some kind of firewall implemented. After re-reading your question though, what is your main issue? Is it that you can't ping, or that you can't access the internet (that is, you can't browse anything)? – Alaa Ali Jun 3 '13 at 5:56
  • Its both. I can neither ping nor access the internet. Cant do a sudo apt-get if that helps. Network B is actually my home network and A is my school network. I guess I need to call comcast ? – canatan Jun 3 '13 at 16:50
  • One last question. What is the output of route -n? – Alaa Ali Jun 3 '13 at 17:30
  • The problem seems to have magically fixed itself atleast for now. Thank you Alaa – canatan Jun 4 '13 at 2:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.