I am running Ubuntu 12.04 I have tried reading different articles online but I am beat. I check my internet speeds they are running at the correct speeds. Yet when on Youtube videos just take ages to get working.

I for the most part us Chromium, although i tried to use firefox to see if this was browser specific and it was not. I get very low loading time for Youtube. I have streamed from other pages with ease.

I tried in creasing cache, updating flash, playing under html5.

( I have 12mb/down speed internet, when i ran videos on Win7 never had an issue my internet could handle 720p)

anybody have a solution?

  • So you say videos from other sites are streaming quickly, and the problem is only with YouTube? What happens when you run Firefox in safe mode? i.e. type firefox -safe-mode at the terminal May 23, 2013 at 4:24
  • i know this is an old question, but did you try installing hal?
    – Nil
    Jun 28, 2013 at 18:51

7 Answers 7


The problem may be that YouTube is using Flash, which is notorious for being slow on Linux. Try going here and clicking the link to participate in the YouTube HTML5 beta. The player isn't as nice, but it should perform better.


I had a similar problem, as you said it has persisted across multiple browsers, and speed checks out. I am assuming Ubuntu is your OS.

1.Try deleting your 'libflashplayer.so' plugins and re-download from adobe. Unpack and move back to plugin directory of your browser.

2.Try clearing (in chromium) your history. Also go to tools in control menu, and clear browsing data. Might be a weird caching problem.

Did you add any extensions? Do other video sites, or flash games work? As a last resort un-install chromium, and remove completely in Synaptic, and all old config files, and reinstall.

Might need a system update, if you haven't tried already. Also reboot system.

Good luck!

  • how would i delete libflashplayer.so sorry im not excactly a pro.
    – user107534
    May 23, 2013 at 4:20
  • Alright. I deleted all my history, caching, cookies since beginning of time and reinstalled Chromium & Flash Plug in from Ubuntu Software Center, seems to be working well. I can play 720p quickly again. Let's see how long this lasts.
    – user107534
    May 23, 2013 at 5:31
  • It started again after 24 hrs
    – user107534
    May 24, 2013 at 3:30
  • Sorry it's been awhile since I connected to internet. I'm glad it started again, to delete libflashplayer.so, it will be in your plugins directory for your web browser, so if you pull up a terminal ctrl+alt+t, you want to change directories by the cd command.'cd /usr/lib' and use the list or ls command to find your browsers directory. Change directory into the browser you want, and find the plugins folder, and there should be the libflashplayer.so file.
    – user159773
    May 27, 2013 at 4:41
  • @kregerjd Never advise to delete system files managed by packages! Remove the package it is part of instead. In this case: flashplugin-installer.
    – gertvdijk
    Jun 28, 2013 at 18:52

In my case I determined that it was actually the audio that was not working properly. That was causing the video to hang. Performing the following fixed my issue:

  1. Make sure pulse audio is installed
  2. rm -r ~/.config/pulse; pulseaudio -k

Reference: No sound device detected


Try installing HAL (hardware acceleraion layer) as per this answer that solved my problems with streaming videos. It seems to make youtube run smoothly too, though I don't know whether I might just be imagining the effect.

The Directions for Raring:

sudo apt-get install hal

sudo mkdir /etc/hal/fdi/preprobe

sudo mkdir /etc/hal/fdi/information

/usr/sbin/hald --daemon=yes --verbose=yes

rm -rf ~/.adobe

Check the below link. May be it will be useful to you.


  • Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Apr 1, 2014 at 10:00

Well just check this..! For Installing 'libflashplayer.so'



HERE IS THE PERFECT SOLUTION: I am also running Ubuntu 12.04, 64 bit. I had same problem util yesterday. The solution is to run the following command to turn off Ubuntu Power Management for your wireless device, usually it will be "wlan0"

1-) Open a "TERMINAL" and type "sudo iwconfig" This will list the available wireless interfaces in your system. Find out your wireless device name. My output is:

lo no wireless extensions.

eth2 IEEE 802.11abg ESSID:"AIRTEL"
Mode:Managed Frequency:2.437 GHz Access Point: 50:67:F0:C7:CF:7C
Bit Rate=54 Mb/s Tx-Power=200 dBm
Retry long limit:7 RTS thr:off Fragment thr:off Encryption key:off Power Management:on Link Quality=50/70 Signal level=-60 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

As you see above mine is "eth2"

2-) Now in "TERMINAL" type "sudo iwconfig >>your wireless device name<< power off" As I typed "sudo iwconfig eth2 power off" That's it. Now check out your youtube videos and tell me the result. For more info check this link -->


  • 1
    From the question: "I check my internet speeds they are running at the correct speeds." So I don't think he has any issues with the wireless power savings.
    – gertvdijk
    Jun 28, 2013 at 18:51
  • Actually I had same issue as described above my internet speed was okay but I couldn't able to open a youtube video fast. It was taking ages to open and then this trick helped me a lot. Jun 28, 2013 at 19:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .