My brother, a Windows Vista user, agreed to have his computer improved by installing the latest ubuntu to it. However, I keep having a weird problem with the Raring Ringtail installation on his Acer Aspire 5710Z: When I ran the system from a live USB, suspend and shutdown worked just fine. Once I installed the system, suspend will bring me back to the password request after showing a black screen for a few seconds. Worse than that: when I shut the system down it does so, but does not power off!

Pressing escape during shutdown shows this output:

* Asking all remaining processes to terminate...                   [OK]
* Killing all remaining processes...                             [fail]
modem-manager[742]: <info> Caught signal 15, shutting down...

* Deactivating swap...                                             [OK]
umount2: Device or resource busy
umount: /var/lib/ureadahead/debugfs busy - remounted read-only
* Unmounting local filesystems                                     [OK]
umount: /run/lock: not mounted
umount: /run/shm: not mounted
mount: / is busy
* Will now halt

This is where it stops. (Same for restart, just the last line says "Will now restart".)

Some posts suggest to manipulate the acpi parameter in the grub file ("force" or "noirq") or switching the speech dispatcher on in /etc/default/speech-dispatcher. None worked for me to get shutdown going. I would terribly appreciate if somebody could enlighten me what the live system and the installed system do so differently that this problem occurs, or at least suggestions what may be worth trying given the console output. Many thanks in advance!

  • run sudo apt-get update upgrade. It's a bug and the latest release of Ubuntu Raring Ringtail update had fix this issue on my laptop. Hope it help. – Shaharil Ahmad May 23 '13 at 5:51
  • Thank you for your reply. Unfortunately, upgrading the system did not fix the problem for me. – Martin E May 23 '13 at 7:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.