On trying to install Ubuntu 12.10 Desktop amd64 to a desktop pc using a ga a75 ud4h motherboard (which is using an AMD 3870k APU with a new 1TB HDD) following the advice in the motherboard manual and https://help.ubuntu.com/community/UEFI have now got to grub option screen for EFI install.

Booting live dvd in EFI mode gives "Secure Boot is not enabled" just before grub kernel option list shows. EFI install

If the option to "Install Ubuntu" or "Try Ubuntu without installing" is selected gives "can not read cd/0" and "the kernel must be loaded first" errors.

Using DVD or USB installation media gives same results and there has never been at any point an UEFI entry in bios/firmware settings or boot device list/s.

It might be helpful to say that have had an alternative non-linux OS installing EFI mode on this hardware giving a GPT installation automagically using USB installation media when the hdd space was completely unallocated space. The USB device was listed under hard drives in bios/firmware one time boot list and did not have an UEFI entry. i.e. it installed EFI although no EFI or UEFI entry was assigned to the device like what is shown in many tutorials regarding UEFI installs.

Am trying to get to live session using EFI mode.
How to edit kernel or load kernel for EFI mode "Try Ubuntu without installing?.

fernando garcía's answer and comments to this Ask Ubuntu question hints at the answer but does not share how. Looking at the manual/website for Grub2 gives the information on how to boot an OS but when running .iso after booting Ubuntu EFI mode from DVD then dropping to command and entering search -f /vmlinuz or search -f /sbin/init no usable kernels are listed due to errors. (No error codes given just confirms bad EFI files.)

The output of ls -l at grub prompt

  • press c to go to the command line and then type ls -l and add the results to your question. – psusi May 22 '13 at 23:32

This is a bit of a long shot, but Gigabyte motherboards with the hybrid EFI have a problem with case sensitivity: Certain comparisons are done in a case-sensitive way when in fact they should be done in a case-insensitive way. My suspicion is that you're running into this problem. You might try to mount the USB flash drive version of the installer with various options for the shortname mount option, move (don't copy) the kernel file (casper/vmlinuz.efi on the disk) off the disk, and then copy it back. This may adjust the case of the filename and make the file visible to GRUB. This type of change is possible, but much harder to do, using CD-R media.

Another option is to upgrade the firmware. Gigabyte lists several updates for this board, and it's possible that one of them will fix the problem. The latest is marked as a "Beta BIOS," and it's possible it's not the buggy Hybrid EFI with which the computer shipped. (Gigabyte offers updates away from the Hybrid EFI on some boards, but I'm not sure if yours is one of them.)

If these suggestions both fail, my only other suggestion is to abandon use of EFI on this computer. If it has a Hybrid EFI, that is a VERY buggy EFI implementation, and it's almost never worth using. If you must, it's likely to be easier to install Linux in BIOS mode and then fix the EFI-mode booting once the basic installation is complete.

  • Thanks for taking time to answer.Have been using F8C firmware since Nov 2012(the beta of the next beta lol)Your gb page and other pages on your useful website indicates it is possible to boot Ubuntu and instal using EFI on very similar hardware.Have never been able to load kernel after launching Ubuntu installer (grub boot manager) EFI mode on this hardware. GB themselves refuse to acknowledge any problem booting non windows os EFI mode.Have been using EFI to boot installed os's for about a year with fair reliability and predictability.BOOT/EFI/BOOTx64 is prob as BOOT/EFI/bootx64 wrx fr rEFInd – geezanansa Oct 10 '13 at 5:22
  • Still does not explain why grub is seeing apple installer as does rEFInd ref picture above partition cd0 – geezanansa Oct 10 '13 at 5:25
  • Have not yet worked out "You might try to mount the USB flash drive version of the installer with various options for the shortname mount option," Have tried " move (don't copy) the kernel file (casper/vmlinuz.efi on the disk) off the disk, and then copy it back. " skipping first part = no difference. Have also tried using the amd64+mac iso after referring to Colin Watson's answer askubuntu.com/a/40480/102029 due to adsvice i overlooked over at launchpad. – geezanansa Oct 10 '13 at 7:47
  • Using the 12.04.3 desktop amd64+mac iso now allows the fallback BIOS installer to run without having to manually change firmware settings to NON-EFI which would mean a non booting installation if allowed to run. For which is the easy fix of installing grub-efi afterwards. 13.10 desktop amd64 did not do this as recent as end of august. – geezanansa Oct 10 '13 at 7:54
  • Re reading the quoted answer by Colin Watson confirms installing Ubuntu EFI mode has existed for more than 2 and 1/2 years and the way it has been resolved is to allow BIOS installer to run. RFLOL Which to me indicates a grub /installer problem not my firmware as windows installs EFI mode just fine with a BIOS install of Ubuntu not needing to rename the existing windows NVRAM entry after installing grub-efi. The linked GB page in answer no where indicates how to boot Ubuntu installer EFI mode only implies it is possible. I guess it is expert knowledge that is to be paid for. – geezanansa Oct 10 '13 at 8:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.