3

Problem: mysql-workbench fails to connect to the keyring to connect to mysql.

I'm trying to get my svn command (which uses an svn+ssh uri) to prompt me to enter my password for my local rsa secrets. Basically, I connected via ssh to the server which hosts svn, and copied over my public key into the .ssh folder in the authorized_keys2 file. My rsa id is protected by a password so that after I login, I still need to enter the rsa password to connect to the other machine. (Forgive me if my terminology isn't correct).

This works great. Now, I can also run ssh-add to enter my password once the entire time I'm logged in. This works fabulous too. I realize that I never remember to run ssh-add before I run 'svn update', so I get the idea from websearches that I could use the keyring to automatcially pop up a dialog box whenever I do a subversion update.

So, I add the following to my .profile:

# Add ssh to the gnome keyring components
eval $(/usr/bin/gnome-keyring-daemon --start --components=ssh)
export SSH_AUTH_SOCK

Once I do this, I see that the ssh-agent is still set in my environment variables. So, I use xfconf-query to set the xfce4-session parameter of /startup/ssh-agent/enabled to false. Great, now My environment variable for the SSH_AUTH_SOCK is using the keyring.

But... mysql-workbench can no longer access the keyring to log in and perform queries.

When I remove the eval and export from my .profile, then mysql-workbench works. When I run the commands manually, mysql-workbench still works, and so does the keyring popup on my svn.

How do I get both the mysql-workbench and svn's ssh request to use the keyring with startup options? (ie what n00bie mistake am I making in my attempts to make the gnome-keyring work?)

I also tried editng the /etc/xdg/autostart/gnome-keyring-ssh.desktop to 'OnlyShowIn=GNOME;Unity;XFCE;', but that had no apparent affect.

Xubuntu: 12.04
Xfce: 4.8
Mysql Workbench: 5.2.38
OpenSsh: 5.9p1
gnome-keyring: 3.2.2
  • Noo-ne noo-ne noo. – Kieveli Jun 17 '13 at 12:09

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.