I want to switch between English and another language.

I have tried Lubuntu and it was easy, I figured it out from the friendly menus. But in Ubuntu everything is so cryptic.


Its as easy to do as in Lubuntu. Click on System Settings, and click on Keyboard Layout:

enter image description here

Click on the "+" sign to add a layout

enter image description here

Search for the language you want, in this example Greek, and add it

enter image description here

Look at the keyboard layout icon, and you will see the new language. Just click it to choose it.

enter image description here

| improve this answer | |

Ubuntu 12.04

Browse to System Settings -> Keyboard Layout -> + button in the lower left-hand corner of the Keyboard Layout window. Click on the + button and a new window will open that looks like this:

enter image description here

In this example I am using Greek as the new keyboard layout language, but you can substitute any other keyboard layout language in the list for Greek in order to add a different keyboard layout language. Select Greek (polytonic) from the menu and click the Add button to add the Greek Polytonic language to the language selection menu that is in the notification area of the desktop panel next to the volume icon and the clock icon.

Ubuntu 14.04 and later releases

The instructions are the same as for Ubuntu 12.04 (and also for Ubuntu 12.10 and Ubuntu 13.04), except for the first paragraph:

Browse to System Settings -> Text Entr* -> + button in the lower left-hand corner of the Text Entry window. Click on the + button (it's marked by the mouse cursor in the below screenshot) and a new window will open that looks like the above screenshot.

enter image description here

| improve this answer | |

Geia soy Georgios. You don't mention the version of Ubuntu you are using, so I will describe how to add polytonic Greek on Ubuntu 12.04.2 LTS which I'm currently using.

Select the System Settings icon from the dash. Alternatively click dash-home and type 'System settings', then click on the icon presented to you.

On the window that has appeared, in the hardware section, you will notice a keyboard icon. Click on that. The content changes and at the bottom you will notice a link "Layout Settings". Click on that. Again the contents of the window change.

On the bottom left you will notice a "+" sign. Click on that and you will be presented a selection dialog. Type Greek in the search field to narrow down the presented options. Now select "Greek (polytonic)" and click Add. You are done.

If you want you can manage some options and behavior of the new layout by clicking on it and then clicking Options. When done, close the window. You don't need to reboot or re-login for the changes to take affect. Ελπίζω να βοήθησα. ( If this is Greek to you, I just wrote that I hope this was helpful :-) )

| improve this answer | |
  • lol A picture is worth a thousand words... – hmayag May 22 '13 at 16:17

You can also use Ibus, which IMHO works a little better than using the keyboard layout when adding the diacritics.

Ibus is installed with 12.04. You need to also install ibus-m17n Install ibus-m17n for polytonic Greek support. This should work with any Unicode font, but you may want to install a specialized free font that is guaranteed to have all of the needed glyphs, such as Galatia SIL Install GalatiaSIL.

After installing these packages, log out and in again.

For instructions on setting up ibus, see this answer. While it's on a slightly different topic, it has full instructions for selecting Ibus as the system imput method and adding an input method. The Ibus m17n method is called is called Greek, Ancient (to 1453)

To add a rough breathing, for example, it's letter + ` (backtick). You shouldn't need to change any key mappings, but if you want to you can change them through the preferences in the language panel. (See the answer linked above for making sure the language panel shows.).

| improve this answer | |
  • I installed the ibus-m17n. I appreciate your help. – Georgios May 23 '13 at 15:20

Look in my case I had HP OMEN so the input coming for @ was " instead and some other minor changes. Look it's simple, you just go to Settings->Region and language (you just type "layout" on the search tab of ubuntu and you would directly land there)->In the input sources you would see English(UK) would have been in use, just click + to add English(US) and the then delete English(UK). Now your laptop should just work perfectly fine!!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.