1

How can i know what packages are available for the Ubuntu LTS. My host says that PHP 5.4 is not supported because it is currently not available on the LTS repo for Ubuntu 12.04. How can I find out if it exists or not? Is there a webpage that I can use to search the availability of a package for the LTS

2 Answers 2

2

Yes, you can search on http://packages.ubuntu.com. Make sure to select (filter) on the precise (12.04) distribution.

Alternatively, check the availability of packages using your package management, e.g.:

$ apt-cache policy libapache2-mod-php5
libapache2-mod-php5:
  Installed: (none)
  Candidate: 5.3.10-1ubuntu3.6
  Version table:
     5.3.10-1ubuntu3.6 0
        500 http://nl.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ precise-security/main amd64 Packages
     5.3.10-1ubuntu3 0
        500 http://nl.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
1

http://packages.ubuntu.com/php5

Look for "precise".

Only PHP 5.3.10 is available for Ubuntu 12.04.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .