Ubuntu One has worked fine for me for several weeks and I now have 8.2 GB of files in the clouds. Then, last night, Ubuntu One stopped working. When I fire up System > Preferences > Ubuntu One, it tells me that I have 8.2 GB stored (13.2 %) and that my status is Unknown.

I've tried to restart to no avail. I even tried to remove, followed by clearing the password keyring and starting over. Still nothing. I've run out of buttons to push.

  • can you post any messages that are produced when you run ubuntu one preferences from a terminal. to do this hit ctrl+alt+t on your keyboard then enter ubuntuone-preferences at the prompt and hit enter.
    – Allan
    Mar 11 '11 at 17:05

What I do is:

u1sdtool -q
find ~/.local/share/ubuntuone/syncdaemon -depth -type d -empty -delete
u1sdtool --start
u1sdtool -c

Sometimes I need to do this 5 times.

Also weird is when I push 'connect' nothing happens, but when I do u1sdtool -c in terminal, it is starting to connect.

I just want to add that since / after upgrade to Ubuntu 11.04 I don't have this problem any more.


I started to ask about this over at Can I reinstall Ubuntu One but here's what worked for me:

u1sdtool -q

Remove .local/share/ubuntuone, Ubuntu One, .cache/ubuntuone, and .config/ubuntuone

I also did ps aux | grep ubuntu and killed two running processes:

amanda    3062  0.1  0.7  45372 23460 ?        SL   07:54   0:19 /usr/bin/python /usr/lib/ubuntuone-client/ubuntuone-login
amanda    7373 13.6  6.1 402320 189516 ?       Sl   10:27   1:48 /usr/lib/firefox-3.6.17/firefox-bin http://one.ubuntu.com/account

Then ...

u1sdtool --start followed by u1sdtool -c

I had to re-connect my computer to Ubuntu One but it seems to be connected now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.