Google released the new Google Maps.

Unfortunately, it doesn't work on Firefox 21.0 on Ubuntu 13.04.

When I open the page, Firefox just draws white grids on the screen. Dragging or clicking the screen does not cause anything. However, when the screen is resized, Firefox draws the current status of the map.

I tried opening it on the Safe Mode, but the result was the same.

Does anybody know how to work it on Firefox?

Note that it works flawlessly on Chrome. In addition, it also works on Firefox on Windows 8, on the same machine.

My machine's graphics card is the following:

 $ lspci | grep VGA
 00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09)
  • 1
    It's working for me (nvidia and on AMD) ont firefox 21.0 ubuntu 13.04. Don't know if it's the graphics card. It's now using OpenGL alright. But if an how it matters, I don't know. – labsin May 21 '13 at 23:20
  • 1
    I have the same problem, but webgl.force-enabled=true doesn't do anything. I'm on a ThinkPad X230. – user161351 May 24 '13 at 5:34
  • @SimonPerreault Then your graphics card must be Intel HD Graphics 4000 of 3rd generation, which is similar to my environment. I don't know exactly why you can't see the maps, but Mozilla's wiki about Blocklisting/Blocked Graphics Drivers might help you. – Akihiro HARAI May 24 '13 at 12:04
  • 1
    According to Google, only Windows and Mac are supported :( – user2856 May 30 '13 at 8:53
  • 1
    @AkihiroHarai yes, I can use the WebGL version on Chrome on Ubuntu too, works well. Most likely it's a Firefox issue, I tried the WebGL version on my Win 7 PC running Firefox at work and it works better than on Ubuntu but still performs poorly. – user2856 Jun 2 '13 at 7:20

I solved the problem.

Just open about:config and set webgl.force-enabled to true.

OpenGL seems to have been disabled somehow.

(June 2, 2013) Update:

The above answer no longer works for me. (Or that was my misunderstanding...)

Use Lite Mode instead.

| improve this answer | |
  • I think that setting is disabled by default on Firefox for Linux. – Flimm May 29 '13 at 8:49
  • It doesn't seem to work for me, even in the lite mode.. Maybe it's my nvidia free driver... – BrunoJCM Jun 2 '13 at 5:36

I set webgl.min_capability_mode to True and crashes are now history.

However, note this problem in running in this mode:

"The Lite mode of the new Google Maps does not include the 3D Earth view or other 3D functionality. However, you can still access satellite maps. Lite mode is enabled by default on some older browsers and operating systems, as well as on browsers that do not support WebGL and on systems where WebGL is known to be unstable. You can see if you are in lite mode by looking for the "Lite mode" indicator in the bottom right corner of the map"

| improve this answer | |
  • Note that this forces Lite Mode to be enabled, same as the link in @Akihihiro's answer. – mlissner Jun 10 '13 at 17:40

Google says that if WebGL is disabled then you are required to use lite mode so I figured I'd play around with those settings.

I set webgl.min_capability_modeand webgl.force-enabled to true and now it is working for me.

As mentioned above webgl.force-enabled being set to true on its own did not work for me.

| improve this answer | |
  • This worked for me. I'm using an Ivy bridge Core i5 with Intel HD4000 graphics, Kubuntu 13.04. – Michael D Jul 29 '13 at 8:07

I had the same issue here and found the solution

From the Mozilla Wiki as per question OP Akihiro Harai:

GL layers acceleration is not yet enabled by default (see bug 594876). You can enable it by setting layers.acceleration.force-enabled=true in about:config.

For those not familiar here are the steps:

  1. Open Firefox
  2. In the address bar type: about:config
  3. Press Enter
  4. Search for: layers.acceleration.force-enabled
  5. Right click on it and select toggle
  6. Restart your Firefox and enjoy

UPDATE: sorry but this does not 100% fix the issue! After trying all other suggestions in this thread I almost got it to work. There only one issue: Street View freezes when I try to move forward / backward in the view. Firefox does not crash and I can close the tab and open a new one, which is ok but far from ideal. If anyone else has any suggestion let us know. Thank you

| improve this answer | |

I had the same problem with an NVidia graphics card. I installed the "nvidia(-313-updates)" driver instead of "nouveau". It's now working...

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.