I have a dual boot set up on a Lenovo Ideapad Y500 with NVIDIA 750M and I am having problems installing the graphics cards. I have made sure to install both linux-headers-generic and linux-source, and yet have ended up with a black screen whether I install nvidia-current, nvidia-current-updates, nvidia-experimental-310, and nvidia-319. I even tried enabling proprietary drivers through settings and still ended up with a black screen on boot. Is my graphics card just not supported yet, or is there a way to fix this?

  • Have you tried creating an /etc/X11/xorg.conf with nvidia-xconfig? – grimpitch May 22 '13 at 17:24
  • Yes, I have done this every time. – aftrumpet May 26 '13 at 3:21

Quick googling gave me this 319.17 Certified

Added support for the following GPUs:

  • GeForce GTX 650 Ti BOOST

  • GeForce GT 720M

  • GeForce GT 735M

  • GeForce GT 740M

  • GeForce GT 745M

  • GeForce GT 750M

So you'll probably need 319.17

It's from 2013.05.02 and not yet in any official Ubuntu repository.

To install it, first remove the ones you installed from the repo's sudo apt-get purge nvidia* (or --purge remove) should do that. If you installed one manually, please look up how to remove them.

Then follow: Install New Nvidia Drivers, Nvidia 319.17, on Ubuntu 13.04 Raring Ringtail

  • I just tried the method and the link. First the installer complained about nouveau still being enabled even though I removed the package and wrote a file to disable it, then I got an installation error. Help? If you need me to I can run the process again to get the exact error message. – aftrumpet May 27 '13 at 20:39
  • You should run it from the tty1 (that's ctrl-alt-F1) Then post the error message :) – labsin May 27 '13 at 22:34
  • Maybe also look in to askubuntu.com/questions/296422/… – labsin May 27 '13 at 22:37
  • Okay, tried some more experimenting today. When I got the error I simply rebooted, and the next time I was able to install the driver. However, now the system only boots into a command line, and when trying sudo startx I get the following error: NVIDIA: API mismatch: the NVIDIA kernel module has version 304.88, but this NVIDIA driver component has version 319.17. Please make sure that the kernel module and all NVIDIA driver components have the same version. How do I fix this, or at least return the OS back to its normal state with nouveau? – aftrumpet Jun 7 '13 at 19:14
  • 1
    Okay, my system is back up, but is there a good solution for successfully installing proprietary drivers that didn't end with the error I had before? – aftrumpet Jun 25 '13 at 16:11

pay attention that there are different nvidia-packages ! the general package is not working as good as the special cuda-sdk-package for cards with optimus-cuda !

here is the solution I have done with my 540M nvidia-card:


  • My laptop doesn't have Optimus (the integrated graphics are disabled). – aftrumpet May 27 '13 at 20:48

Blackscreenn after installing a new nvidia driver: push the key "FN" and "Up". You only have to lighter the screen.

  • That's not the issue. What I mean is that it won't boot properly, with just a flashing cursor displayed. – aftrumpet Jul 4 '13 at 20:48

Used the GUI to enable proprietary drivers several days ago, and to my surprise it worked. A couple month's worth of updates must have fixed the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.