71

I am trying to boot Ubuntu 13.04 in VirtualBox, but every time I boot, I get an error that says:

SMBus base address uninitialized - upgrade BIOS or use force_addr=0xaddr

This happens right after I start the virtual machine, and the operating system does not even start properly. I see the error, then the screen just goes black and gives me a blinking cursor. The solutions I have found online tell me to open up a terminal only after the OS boots correctly. Sadly, I cannot even get to that stage, so I can't use that solution.

Help?

By the way, I am VERY new to Virtual Box and creating virtual machines, so excuse me if I'm not familiar with some of the terminology. Another thing, if it helps, is that I'm running Windows 7 as my host OS.

  • 1
    Have you considered accepting Guest_vh's solution as an answer? – Mike Jan 29 '15 at 20:51
  • Guest_vh's answer may not resolve the issue and will slow down your guest. The correct answer is here - everyone simply needs to upgrade to VirtualBox 5.1.4 (although it's perfectly safe to simply ignore this warning, since it's only cosmestic) – Code Bling Dec 16 '16 at 20:15

20 Answers 20

76

Turn off the option "Enable Nested Paging" in the VirtualBox configuration under Settings->System->Acceleration.

This allowed me to get Ubuntu running with the desktop.

  • 2
    This worked for me when trying to install Xubuntu 14.10 on VirtualBox 4.3.18_Ubuntu. It seems like the simplest solution by far. Hopefully the author will accept it as the answer. – Mike Jan 29 '15 at 20:51
  • 1
    Confirming this works with Ubuntu 15.04 as well. – arhuaco Jun 9 '15 at 19:14
  • BEWARE: Applying this fix could cause your VM to do this: bit.ly/1S3Wukj (guest OS is Xubuntu 15) – MikeM Feb 25 '16 at 17:20
  • Didn't work for me, virtual machine still won't boot (guest OS Ubuntu Gnome 15.10, host W10). – 0x6C38 Mar 9 '16 at 5:11
  • 2
    This is a bug with VirtualBox. Disabling Nested Paging will slow down your VM and is not recommended, particularly in an attempt to eliminate an inconsequential error message. See my answer for details. – Code Bling Oct 19 '16 at 17:35
24

This answer is copied from Blog of Finster » VirtualBox piix4_smbus Error, slightly modified:

SMBus base address uninitialized - upgrade bios or use force_addr=0xaddr

This error is caused by VM having no smbus but Ubuntu always trying to load the module. It doesn't affect anything but is a bit annoying.

  1. Check module is being loaded

    lsmod | grep i2c_piix4
    
  2. If so, blacklist it in the file /etc/modprobe.d/blacklist.conf, by adding the following to the end of the file:

    blacklist i2c_piix4
    
  3. Update the initramfs

    sudo update-initramfs -u -k all
    

You might want to optionally remove unneeded kernel images before updating the initramfs to cut down on how long that part takes.

  • 2
    MountainX sorry to say you are wrong it does affect something it will stop you from loading Ubuntu into a virtual state so in that term it does affect something you will end with a black screen for hours no matter speed or such I got the same results trying it with the information. – user256572 Mar 9 '14 at 23:51
  • Your comment doesn't make sense to me... However, if you think this information is wrong, please take that up with the person who wrote it at the link I gave. I only copied that information here. – MountainX Mar 10 '14 at 1:38
  • So, so because there was a warning for one bus, disable the entire chipset driver? This does not make sense to me. – Code Bling Oct 19 '16 at 17:38
  • Where do you type these commands? In Ubuntu terminal or in windows?? – ltdev Nov 15 '16 at 20:50
11

We can safely ignore the warning

SMBus base address uninitialized 

This indicates that we run without a System Management Bus, which is to expected on a virtual machine.

Your boot failure does have a different reason. Anything from incompatible settings of your virtual machine to incompatibilites with your Windows kernel or drivers.

Try to boot the virtual machine while pressing and holding the left Shift key to boot a root shell for further investigation, to upgrade your guest OS, or to install the guest additions.

7

The "SMBus base address uninitialized" message is an issue with VirtualBox. It's purely a cosmetic issue, and will not affect or hinder the operation of the virtual machine.

This is FIXED in VirtualBox 5.1.4. (change logs) Upgrade to the latest version of VirtualBox to eliminate the error message.

Disabling Nested Paging, as suggested in some answers, will not eliminate the "SMBus base address uninitialized" message. In addition, it will likely make your guest OS slower.

The fact that your machine won't boot is a different problem. You'll need to find a way to check the virtual machine's boot log.

  • 1
    You are my hero! – house9 Jan 9 '17 at 19:57
  • 2
    Remind that upgrading VirtualBox may make some of your images not to load anymore. – polkovnikov.ph Mar 7 '17 at 14:50
  • @polkovnikov.ph I suppose it's possible, but generally shouldn't happen. What version were you upgrading from/to, and what happened? – Code Bling Mar 8 '17 at 4:29
5

The error message is not related to the problem of Ubuntu not booting. I have had the same problem. After displaying the error message the colors became crazy and the system seems to halt, however moving the mouse resulted in some pixel garbage.

Disabling "Nested Paging" in Setting->System->Acceleration allows to start the system.

Tested using VirtualBox 4.3.20 (64bit on Windows 7) with Kubuntu 14.10. After changing the setting, I was able to boot and install Kubuntu, however the error message appears on every boot.

2

If you have ICH9 available, switch to that instead of the PIIX3 chipset (Settings->System->Motherboard). Support for it is 'Experimental' by VirtualBox, but it's stable on my Mac Book Pro host.

  • Worked. So easy! – alanjds Oct 19 '16 at 14:43
  • 1
    This appears to be the simplest of the working solutions. But I surmise that the source problem is due to tight memory allocation for the virtual hard disk. The problem appeared to me when under 500MB available (have not done testing on this threshold) – Jerome Jul 15 '17 at 12:28
  • Thanks for the good feedback @Jerome . I don't recall my VM being very short on virtual hard disk space, but that very well could have been the problem. If you increase your VM hard disk allocation, then the problem goes away? – pranspach Jul 17 '17 at 19:40
  • that is my experience, yes. Note: something weird does go on: I had allocated 12 GB to the VM HD, but when I run Ubuntu's disk analysis, I have total capacity of 6, with 0.6 available... – Jerome Jul 18 '17 at 7:24
1

I am running Virtual Box 5.0.0 r101573 on Windows 7 Enterprise SP1. Ubuntu 15.04 has the problem listed, which went away after I unchecked Enable Nested Paging.

1

I got the same error as mentioned by OP while installing Ubuntu 14.04 for the first time on VirtualBox 5.0.4r, Windows 7 (64 bit) (see screenshot).

Guest_VH's answer did not work as the fields were greyed out, so I could not uncheck the box for "Enable Nested Paging".

Here is the the solution that worked for me:

Hit "Enter" key after you see that error screen. Voilà! It logged right in for me.

  • 1
    I think the fields were greyed out because you had the VM running at that time. The VM needs to be off before you can change its system settings. But no matter, because it seems like you found a better solution! – wjandrea Dec 16 '16 at 20:40
1

This message appeared in my VirtualBox while I was installing/starting Ubuntu 15.10. (The same problem occurred for previous versions as well.)

Solution

  1. Restart the host computer.
  2. Go into the BIOS settings.
  3. Enable Intel® Virtualization Technology (Intel® VT).
  4. Save the BIOS configuration and reboot.
  5. Start VirtualBox.
  6. Press Ctrl+S or right click on your guest OS and click Settings.
  7. Go to System -> Acceleration.
  8. Check Enable Nested Paging.

Acceleration settings

Boot the Ubuntu guest, and walla it works without any problem.

1

I encountered the same issue after an Ubuntu software update. (The kernel image was updated with this batch of updates.)

Workaround

  • Enter Grub menu recovery mode for your kernel.
  • Result: The OS loads completely.

A persistent workaround

  • Edit /boot/grub/grub.cfg and add nomodeset after quiet splash.
  • Result: The OS will load completely even after restarts.

Solution:

Once inside the OS (after a successful boot), reinstall the VirtualBox Guest Additions.

Note: The error message still shows up even when the workaround/solution is applied.

Host: OS X Yosemite 10.10.3
Guest: Ubuntu 15.10 (Lubuntu)
Kernel: 4.2.0-25 generic (updated from 4.2.0-16)
VBox: 5.0.14

  • I think you mean /etc/default/grub instead of /boot/grub/grub.cfg. – wjandrea Dec 16 '16 at 21:04
0

Encountered a similar issue and the same fix worked for me. On my pc i get a blank screen and in VirtualMachine i get the force_addr=0xaddr error after upgrading from a workstation.

Found the fix at: My computer boots to a black screen, what options do I have to fix it?

Just hold Shift when starting to get into GRUB, press E to edit the entry, search for "quiet splash" (without commas) erase that and type in "nomodeset" (no commas) and then press Ctrl+X to boot.

I actually typed just "nomode" once and it still booted for me.

0

Solved in my case.

When I loaded a virtual Mint 17.1 on a Virtualbox 5.0.0, I stranded in this situation. I tried the procedures shown by MountainX.

Next, an another error (No support for locale: en_US.utf8) occured and was solved by this command:

locale-gen --purge --no-archive

After that, I encoutered a login loop and attempted to solved it with a following article (Japanese):

http://kledgeb.blogspot.jp/2013/03/ubuntu-x-3.html

rm -f /home/<user>/.ICEauthority
rm -f /home/<user>/.Xauthority

Finally a virtual mint 17.1 works well on a VirtualBox 5.0.0.

I wish this will help you.

0

I think it is a common problem caused by not changing the boot order from 'optical disk' to 'hard disk' and can be remedied by 'Power off' the VM then selecting the "System" setup option in the VM and UNcheck the "Optical Disk" selection in the boot order. Then try again ...

I sometimes forget to do it too and have been using VM's since dinosaurs ruled ... :). I also move the "Optical Disk" down in the selection order but doubt that matters - it is not a real 'BIOS' option for the VM even tho' it does act like it.

It could of course be something more sinister/complicated but this method has always worked for me.

HTH ...

0

Turn off other virtual machines. This includes "saved-state" machines.

Whew, I thought I was in trouble for a second there.

Running Ubuntu 16.04 i386 on a 64 bit system; decided to install a 64 bit version of Ubuntu on a virtual machine. I looked up everything and it says I can do it.

When I ran the ISO on the VM using Oracle Virtualbox, I kept seeing an orange error on boot similar to this one:

SMBus base address uninitialized - upgrade BIOS or use force_addr=0xaddr

Then the display was all colors and blocks and you know was like "This is a test of the emergency broadcast system..."

It didn't say that; it just looked like that to me.

Anyway, I have another VM on Virtualbox that I'd left in a "saved state." I force quit her. I was able to boot to the ISO on the PIA machine after that.

0

Same symptoms as The Emperor of the Republic when installing Ubuntu 16.04 LTS desktop to vm on Virtual Box 5.0.20. Changing to 2 processors and 48MB Video memory and disabling Nested Paging under System / Acceleration permitted installation, but had similar screen on reboot. Booted into grub recovery mode took care of it.

0

Got the same problem and tried @Guest_vh way still not working.

The solution that worked for me was pretty simple. I updated my Virtual Box, before i was using 5.0 version, after update to version 5.1.8 it's work without problem :|

0

I got this error after playing with partitions, in my case was a problem with the swap partition. And the problem was that in /etc/fstab I had a line like this

UUID=33b1d2c1-84cb-4ccf-a5f6-30dcf6174e49 none            swap    sw              0       0

But the UUID was no longer valid. So the system was a little bit crazy trying to mount the partition, and ended without mounting any swap space. The command blkid gives you the actual UUID for your partitions.

-1

I am loading a virtual Ubuntu 14.04 onto a virtual Mint 17.1.

The error was the same however I just continued to boot until it booted up. We're talking about a host to guest in which becomes the host to another guest. Don't get concerned about errors, just simply get back up and start "walking" again.

-1

I started receiving the exact same error when starting a VM of Ubuntu 14.04 inside VirtualBox. In my case the acceleration options mentioned by maytham were grayed out. I was able to correct the issue by increasing the processor execution cap from 1% to 41% (Settings->System->Processor). image of VB system>processor options

-1

Only Enable EFI checked allowed me to be able to install, just saying.

It's on one the tabs in system, where I was looking about the nested option.

(I must provide a more complete answer, with the exact details. Latter.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.