0

12.04.2 workstation where I am using ibus to write in pinyin. Recently it has stopped responding.

If I select the ibus keyboard icon from the menu, I get presented with the menu list of no input window and I can not quit, restart or click on preferences.

I was able to temporarily get this working again by deleting my $HOME and setting it up from scratch but shortly after it stops responding once again.

I configure it from settings → Install / Remove Languages and install Chinese Pinyin. I also enable it from command line with im-switch -s ibus

Would anyone have any experience with this problem or have suggestions for where I can look to troubleshoot.

3

I was able to recreate this problem exactly when I ran im-switch from the command line. The ibus indicator appears on the menubar, but does not respond.

I haven't tracked down the exact problem caused; but running im-switch after setting up ibus probably leaves the IM setup in an unstable state, running it by itself does not appear to handle all of the needed steps to setup the IM.

There's no need, however, to run im-switch manually since the language-selector handles all the necessary configuration and setup on the backend automatically.

I fixed the problem by resetting the IM method to None so language-selector will reset the changes on the back end, logging out and in again, then going through all of the steps to set up ibus and pinyin input from scratch. (There may be a way to fix it through command line or editing the config files, but the GUI is quick and easy here.)

First, as an aside, you don't need to enable Chinese language support to type Chinese through pinyin input. The language support is for menus, applications, and system use.

For pinyin input (or any input), you only need the packages required by the input method; here it's ibus-pinyin. This should be already installed with Precise 12.04.

Open Language Support from System Settings

If you don't need Chinese menus, etc, you can ignore Install/Remove Languages, but in Keyboard method input system, choose Ibus.

Choosing the IM method from here automatically handles all of the backend setup for you. It's a good idea to log out and back in before doing anything else.

If ibus is already selected, you need to clear the configuration changes that came from running im-switch manually. Simply choose None and language-support will handle the needed backend reset. Log out and back in. Then choose ibus and log out and in again.

Screen shot from Language Support

Set Ibus Preferences and Input Methods

After logging back in, the ibus indicator should work as intended now. (You can also start the preferences dialog from the command line with ibus-setup.)

As an aside, on the General tab, it's a good idea to change Show language panel to When active or Always. There is a bug or conflict somewhere that keeps the default option of Embedded in Menu from working. The language panel provides additional functionality, such as choosing simplified or traditional characters, and has advanced options for the pinyin method.

enter image description here

Then choose the Input Method tab. Choose Customize active input methods. Please note that installing Chinese (or any) language support does not automatically set up an input method. You still need to do this separately.

Use the Select an input method button to access the sub-menus of Chinese and Pinyin.

Ibus preferences general tab

The Select an input method text will change to Pinyin. Then click Add.

Ibus preferences input method tab

You should now see Pinyin in the list of installed input methods. Then click Close.

enter image description here

Ibus can sometimes be a little finicky when using the menus for the first time. You may need to click Preferences more than once after logging back in. (Possibly there's still some configuring going on in the background before it's ready.)

Also, once you have added the input method, you should see pinyin in the menu right away. But a few times with a new install I have had to force Ibus to see an input window first. If that happens, just open an editor like LibreOffice Writer or Gedit and click in the document window.

3
  • I may have been a little unclear here. im-switch was run after the initial set up not the second time when I reset up pinyin input as you mention above. after the second time resetting up pinyin it still breaks. is there a need to backout the im-switch changes? – Jan Geep May 20 '13 at 18:42
  • 1
    The problem is coming from running im-switch manually (rather than letting language-support call it behind the scenes and automatically take care off all additional setup issues). The gist is that, yes, you want to undo the changes from im-switch and then set up ibus again normally. Running im-switch recreated the problem. Setting the IM to none, logging out/in to reset the session, then setting ibus up normally fixed it. I see that my original answer was unclear on the need to reset the changes made by im-switch and clarified the answer in 2 places. – chaskes May 20 '13 at 19:35
  • ah ok. I see now. It looks to be working again so all is good. thanks! – Jan Geep May 21 '13 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.