0

I'm trying to use gnome-session-fallback on an Ubuntu PC running an xrdp+vnc server (So that I can remotely connect to Ubuntu using a Windows RDP client). The problem I have is that the “d” key seems to be bound to the action “hide all normal windows”, even when I am using a program that captures text. This is a bit annoying because everytime I would press “d” I need to copy and paste a “d” character instead.

I went into “System Settings” > “Keyboard” > “Shortcuts” and found that the action was bound to “Alt+Super+d”. I tried binding the action to another key sequence, but (as expected) it didn't fix my problem.

At first I assumed this was because the setting I changed is for Unity and not for Gnome fallback, but if I just log in normally using Gnome fallback “d” does not minimise all windows – it just works normally.

I also tried connecting directly to the vncserver, from my localhost and got the same behaviour.

I get the same behaviour regardless of whether I use a Windows, or Ubuntu based client. The instructions I used for setting up my Ubuntu xrdp+vnc server are here:

http://www.unixmen.com/install-xrdp-in-ubuntu-13-04/

Does anyone know why this is happening?

Is there any further information that I can provide?

1

The answer is here.

I needed to update my settings using CCSM.

Steps I followed:

  1. Open a terminal and run "sudo apt-get install compizconfig-settings-manager"
  2. Run the compiz config manager from your terminal: ccsm
  3. In the compiz config manager navigate: General -> General Options -> Key bindings
  4. Set the key binding for "Show desktop" to whatever you want it to be (or disable).
  5. Click OK
  6. Click Back
  7. Click Close.

Unlike the linked article I didn't have to restart anything, it worked straightaway.

  • Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Basharat Sialvi May 20 '13 at 21:41
  • My apologies - I made the last update from my phone. The steps I followed are almost the same as the linked article. – James Packham May 23 '13 at 12:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.