I'm puzzled because my phone used to just appear when I plugged it in. It doesn't anymore and The development options are definitely set to allow USB debugging. The phone is charging via USB but doesn't appear in lsusb

[0 amanda@luna android-sdk-linux_86]$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 17ef:4807 Lenovo UVC Camera
Bus 003 Device 012: ID 413c:1003 Dell Computer Corp. Keyboard Hub
Bus 003 Device 003: ID 08ff:2810 AuthenTec, Inc. AES2810
Bus 003 Device 013: ID 413c:2010 Dell Computer Corp. Keyboard
Bus 003 Device 014: ID 046d:c001 Logitech, Inc. N48/M-BB48 [FirstMouse Plus]

adb devices -l shows nothing.

In my Wireless and Network settings I changed the USB connection settings to "Mass storage" -- they were set to "Ask on connection" though I definitely wasn't getting asked. I don't get any Click here to connect via USB alert either.

I'm not even sure whether the issue is my phone or my computer. It seems odd that it isn't even appearing in lsusb

Not for nothing, the thumb drive on my keyring also does not appear in lsusb -- I've tried both in a bunch of different ports. I kind of assume the thumb drive is just borked, but it could be my OS.

  • 7
    It could be a dodgy USB cable, allowing power but no data. I'd try another (and another port), just in case.
    – Oli
    Commented May 20, 2013 at 12:23
  • 2
    WTF? That works. My head is going to explode. It never occurred to me that the cable might be the problem. Grrr. Anyway. If you want to make that an answer I'll accept it.
    – Amanda
    Commented May 20, 2013 at 12:26
  • My Ubuntu used to mount mtp filesystems until I updated to 20.04 and now it doesn't.
    – n8chz
    Commented Aug 6, 2020 at 17:42
  • 1
    hah. wriggled my cable and it worked. ugh duh thanks.
    – gaoithe
    Commented Apr 7, 2023 at 22:00

4 Answers 4


Android doesn't support mounting your phone as a USB mass storage device anymore as of Android 4.x. It's all MTP now. Installing mtp-tools should make lsusb list your device. To mount your device as a drive you have to follow a few more steps. Check this site: http://www.mysolutions.it/mounting-your-mtp-androids-sd-card-on-ubuntu/

... but that doesn't solve the mystery of your thumb drive not appearing anymore...

  • 1
    Someone pulled the "gingerbread" tag, but it is relevant that my phone is gingerbread--which still supports USB Mass Storage.
    – Amanda
    Commented Jun 3, 2013 at 22:17
  • 4
    That was the wrong answer, but the info that I was looking for. Thanks.
    – Carsten S
    Commented Apr 16, 2014 at 14:45
  • 3
    Link is broken.
    – gerrit
    Commented Aug 29, 2021 at 12:12

If this were me I would try:

  • Restarting the phone. Sometimes a power cycle is all it takes.

  • A different cable. They're surprisingly fragile things with no internal redundancy. Mass production has done nothing to enhance their longevity. Most people have about a thousand of these cluttering up their houses so it should be a simple swap.

  • A different port. They can break and internal connectors can fall out.

  • A different computer (assuming one is conveniently close by). I once had a problem with a USB chipset that refused to talk to a SGS2 in download mode. Everything else was fine but the SGS2 would just make the USB subsystem hang. Tried it in a laptop and it just worked.

  • 4
    None of the 3 worked for me. However restarting my Phone did the trick.
    – Tino
    Commented Feb 5, 2016 at 21:05
  • 1
    @tino edited the answer to include that. :)
    – Amanda
    Commented Oct 31, 2018 at 16:48

Android 7.1.x onwards (I think, but could be from 6.x also), the USB-cable connected to the device is put into charging-mode-only. This is to avoid filesystems crashing when disconnected without proper unmounting. You must switch to file sharing mode on your phone to transfer files.

After connecting your phone to your computer, go to your phone's settings and search for "usb" or "cable" and look for the option that says "Enable File Transfer" (or something to that effect). Then, the phone will declare itself as a USB device and lsusb in Linux will show the device. Then, you install the ADB Linux toolkit (using apt install <blah> on Ubuntu/Debian or dnf install <blah> on Fedora) and you can then use: adb shell your-linux-shell-cmd-here.


I've got a Motorola phone (Moto e) running Android 10. First thing I did was to become a 'developer' on the phone following the instructions from this site:

Yes you actually have to tap keep tapping on 'Build Number' ~10 times. (odd interface IMHO)

Once you become a 'Developer', on the phone, go to 'Default USB configuration' (in the Networking category)

  System->Advanced->Developer Options->Default USB configuration

Set it to 'File Transfer'. Now, when you hook up your phone, you'll hopefully be able to see your files with the File Manager (I'm using Thunar).

So, the MTP stuff seems to choke now:

$ mtp-folders
error returned by libusb_claim_interface() = -6LIBMTP PANIC: Unable to initialize device

And it doesn't appear that anything gets mounted at all, so I haven't really answered the question, but at least you can get your files/pictures off.

  • The selected answer did in fact work.
    – Amanda
    Commented Feb 3, 2021 at 22:21
  • Ubuntu 21.04 should connect and mount without troubles. If not, the trouble will lie with the phone. Users must ensure: 1/ they have invoked the 'developer' access. 2/ invoke the 'sharing' function. this is done via the phone menus. 3/ invoke the usb file transfer function mtp. this should show on phone after connecting via usb wire to desktop. Use the desktop file manager to see the phone mounted, then go through the directories to find files on the phone. It all sounds complicated the 1st time, but the 2nd time is easy.
    – rob grune
    Commented May 22, 2021 at 13:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .