0

I just installed bumblebee and primusrun in my Ubuntu 12.04.

I can execute applications like totem successfully through vblank_mode=0 primusrun totem in terminal. My doubt is how do I edit the .desktop files located at /usr/share/applications to choose nvidia as default?

I changed this line at totem.desktop file: Exec=vblank_mode=0 primusrun totem %U

But when the file is with this configuration I cannot launch totem through Unity launcher. Am I doing something wrong here?

  • Not an answer but you have to run this command for application : vblank_mode=0 optirun -b primus %command% – Qasim May 20 '13 at 0:44
  • Apparently vblank_mode=0 primusrun and vblank_mode=0 optirun -b primus are equivalent, I got the same results from both. That also doesn't work in .destop files. – Humberto Ferreira Da Luz May 20 '13 at 1:36
  • Well i do not get the same result that is you ...its good if you have same results – Qasim May 20 '13 at 2:22
  • Do you really need the vblank_mode=0? Unless you have problems with it (e.g. shearing), you're probably better off (e.g. most of the time there's less shearing, and less waste) without it. It's used on benchmarks, because it deliberately caps work that will normally be wasted, but one normally wants to watch videos more often than benchmark the tools for them. – Jon Hanna Oct 7 '14 at 21:57
0

Well that command doesn't work for me either in Ubuntu 13.04, but, the idea I once had turned to be true: the solution is to make a script in /usr/bin.

$ sudo gedit /usr/bin/optiprime

now enter: #! /bin/sh vblank_mode=0 primusrun "$@"

save and

$ sudo chmod +x /usr/bin/optiprime

To use primus with whatever you want just type

$ optiprime <command>

which can be used with no problem in .desktop files

  • however, xonotic an nexuiz seem a little unstable on default settings in normal mode, and in high mode seem more unstable. Instead, although virtualgl with jpeg transport perform slower in glxspheres test, they are quite stable in high settings (effects) mode even more stable than primus. I have an i7 Asus k55vd 15.6” laptop with 8 gigs of ram and 2 gigs nvidia 610m. – cyberalex4life Jul 18 '13 at 18:37
0

First, I strongly recommand do not modify files under /usr as they may be override by an upgrade. Make a copy in your personal folder

cp /usr/share/applications/org.gnome.Totem.desktop ~/.local/share/applications/

Then modify the content and the title, here an example

nano ~/.local/share/applications/org.gnome.Totem.desktop

And change the line according to my example (change xx by your language).

Exec=env vblank_mode=0 primusrun totem %U
Name[xx]=Vidéos (Primus)

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.