As a newb, I have been playing with my setup. Now, I get a

waiting 60 seconds for network configuration
Waiting up to 60 more seconds for network configuration

On boot and then when the UI is loaded the following errors appear:

Could not connect to wicd's D-Bus interface. Check the wicd log for error messages

The wicd daemon has shut down. The UI wpipll not function properly until it is restarted

I have searched the HDD for wicd.log nothing there.

I need to sort this out, so if anyone could help me to get my network back, I would love to give it a try.


I run a Sony Vaio VGN-AR71E. Wireless network card connecting directly to the Internet via a wireless modem

  • Another Error is Error connecting to wicd service via D-Bus – SimplySimon May 19 '13 at 18:10
  • 1
    1. logfile should be /var/log/wicd 2. please confirm the upstart service for wicd is started. The 2nd one is probably not the case (hence the error ;) ) – Rinzwind May 19 '13 at 18:15
  • Looked in /dev/ no log folder though – SimplySimon May 19 '13 at 18:26
  • @Rinzwind sorry, no log file and I don't know how to see what services are running. But I think it can not be. How do I start it? – SimplySimon May 19 '13 at 18:45
  • I'm trying now to find a network proxy that is not compatible with the system. – SimplySimon May 19 '13 at 18:59

My guess as to what you did wrong is you installed wicd and then after the installation was finished, you didn't completely remove the old network manager by running this command:

sudo apt-get remove --purge network-manager-gnome network-manager

Therefore you've got two different conflicting network managers, and you can't connect to the internet.

  • Thank you for the suggestion, I have just run that command and the results are the same as before. I think I need to delete the current network settings and reload the network manager, but I don't know how to do this. – SimplySimon May 20 '13 at 8:36
  • Fixed it the hard way! Firstly I tried to repair the installation, that failed so I shifted everything important on to a separate HDD and wiped Ubuntu and reinstalled all the programmes again :) I should have finished adding all my email accounts (10) and contacts by 10am tomorrow. Thanks for your help. – SimplySimon May 20 '13 at 22:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.