I have moved my HDD with Ubuntu 12.04 to a new PC, but the wired LAN didn't worked, so I have booted the computer from a 13.04 USB stick to see if it is working there (it works), and started the installer with the upgrade option, but stopped it at the step when it asks for my real name (it is one of the first steps).

Now I have got an error saying something like Invalid or corrupt kernel image... when trying to boot from the HDD.

I have checked the partitions with GParted, and they seems to be fine.

Is it possible to somehow fix the old installation?

Update: Sorry, this error message only occurs when trying the "Boot from first hard disk" option from the UNetBootin menu.

The following error occurs when I remove the USB stick and try to boot from the HDD:

mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /proc on /root/proc failed: No such file or directory
Target filesystem doesn't have requested /sbin/init.
No init found. Try passing init= bootarg.
BusyBox v1.18.5 (Ubuntu 1:1.18.5/1ubuntu4.1) built-in shell (ash)
Enter 'help' for a list of built-in commands.
(initramfs) _

Update2: Tried Boot-Repair as bodhi.zazen suggested, and got the following error:

Missing operating system.
Reboot and Select proper Boot device
or Insert Boot Media in selected Boot device and press a key

Here is the repair log: http://paste.ubuntu.com/5680854/

Update3: I can't see the /dev, /proc and /sys folders on the old partition. I think that the updater already deleted them...

Update4: I have lost the /etc and /var directories as well (with lot of data and a vboxed windows). Tried many recovery application with no luck... Everything was messed up so I ended up with reinstalling and recovering from backups...

1 Answer 1


Boot the install to an older kernel (it should be "previous linux versions")

enter image description here

Remove and re-install the new kernel.

You could try:

sudo apt-get -f
  • Please see the updated question. Tried to boot to a previous version, but always got the same errors mentioned in the update.
    – styu
    May 19, 2013 at 15:38
  • 1
    Try booting an old kernel directly , without the live USB. If that fails run boot-repair from the live usb help.ubuntu.com/community/Boot-Repair
    – Panther
    May 19, 2013 at 15:47
  • Tried an old kernel without the USB stick with no luck.
    – styu
    May 19, 2013 at 16:27
  • Run boot-repair from the usb, see the link I gave you.
    – Panther
    May 19, 2013 at 16:31
  • Thanks for the link, already run it, but now I got the message in the updated question (Missing operating system).
    – styu
    May 19, 2013 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.