In the past I was able to get my webcam working with Skype using the fix described here:

Skype video not working after upgrade from 11.10 to 12.04

It meant starting skype with:

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype

This worked well on Ubuntu 12.04, but doesn't work anymore on Ubuntu 13.04. Probably because the executable file in /usr/bin/skype is replaced by a script that says:

# Tip in https://launchpad.net/bugs/1002187, comment #31
# Bug filed against Skype: https://jira.skype.com/browse/SCL-980
export LD_PRELOAD="/usr/lib/i386-linux-gnu/mesa/libGL.so.1${LD_PRELOAD:+:}$LD_PRELOAD"
exec /usr/lib/skype/skype "$@"

It seems that this script is needed to work around a bug to start Skype on Ubuntu 13.04 but it is probably also overriding my own webcam fix and I guess that's the reason it is not working anymore.

So I need to add my webcam fix to this script, but I have a hard time finding out how? Any help with this?


2 Answers 2


I fixed this by creating the file /usr/local/bin/skype with the following contents:

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/lib/skype/skype

And making it executable:

sudo chmod a+x /usr/local/bin/skype

I had a fresh Raring install so I also needed to install the 32bit libs.

sudo apt-get install ia32-libs
  • 1
    Nice that this fix works for you on Ubuntu 13.04! But it isn't working for me, because Skype crashes with a segmentation fault. Most likely because of bug bugs.launchpad.net/ubuntu/+source/skype/+bug/1002187 That's why the package maintainer of Skype replaced the executable in /usr/bin/skype with a script that does some LD_PRELOAD magic and I need that fix for Skype to start, but I would also like to get my camera working.
    – joris
    May 21, 2013 at 11:18
  • Right, yeah, I must not be affected by the other bug.
    – gacrux
    May 21, 2013 at 23:06

Just fixed it! There is a new version of Skype, version 4.2 You can install it from the Skype website. They didn't fix the long standing issues that a lot of people have with their webcams, but it seems they did fix the segfaulting issue. So /usr/bin/skype is not a script with some LD_PRELOAD magic anymore but an executable file.

This makes the webcam fix from: Skype video not working after upgrade from 11.10 to 12.04 also working again. Great!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .