Is there a ppa I can use to install Sigil in Ubuntu?

The old ppa:rgibert/ebook doesn't work for me any more.

  • per rafal's answer it's standard in apt. works for me. – Thufir Mar 27 at 8:22
up vote 1 down vote accepted

You'll rarely find last version of Sigil in any ppa (0.7.2 there, 0.7.4 the last one).

The sunab/sigil-git ppa states it is for testing only; it uses "the latest git snapshot from git master branch of Sigil a WYSIWYG epub editor".

You can try the deb (now updated to 0.7.4) shared, with instructions, at mobileforums:

http://www.mobileread.com/forums/showthread.php?t=211754

I found an external repository called ppa:sunab/sigil-git that contains the last version of Sigil, using Qt5. To install it:

sudo add-apt-repository ppa:sunab/sigil-git
sudo apt-get update
sudo apt-get install sigil

Edit: it seems sunab repository wasn't updated for Ubuntu 15.04.

  • 3
    It is a testing-only repository – To Do May 26 '13 at 13:08

The latest version Sigil 0.8.2 is available only here at the moment:

sudo add-apt-repository ppa:i2p.packages/i2p
sudo apt-get update
sudo apt-get install sigil
  • Been fighting with this all day, and this was the only thing that managed to work for me. – Travis Weston Jan 14 '15 at 22:58

Ubuntu 16.04

Sigil is in official repositories for Ubuntu 16.04, so you can install it without adding any 3rd party PPA:

sudo apt-get install sigil

Version in repositories is 0.9.5, which, is most up-to-date version released so far.

FWIW,

Additional, you need the more up to date qt5 libraries, Found in ppa:ubuntu-sdk-team/ppa

sudo add-apt-repository ppa:sunab/sigil-git

Otherwise installing Sigil will fail due to older qt5 in the standard repositories.

There are some repositories that seem to be mantaining Sigil at this moment for Ubuntu 15.04:

i2p: https://launchpad.net/~i2p.packages/+archive/ubuntu/i2p

sudo add-apt-repository ppa:i2p.packages/i2p
sudo apt-get update
sudo apt-get install sigil

xiota: https://launchpad.net/~xiota/+archive/ubuntu/ppa

sudo add-apt-repository ppa:xiota/ppa
sudo apt-get update
sudo apt-get install sigil

mapreri: https://launchpad.net/~mapreri/+archive/ubuntu/sigil

sudo add-apt-repository ppa:mapreri/sigil
sudo apt-get update
sudo apt-get install sigil

Though it is important to note that i2p.packages repository doesn't contain only Sigil, and updating after adding it may upgrade other packages.

This might go against the grain for a few people, but the Windows version works fine in WINE...

Windows Version Here

The xiota ppa has also been keeping up to date on sigil:

sudo add-apt-repository ppa:xiota/ppa

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.