This is my first time using Ubuntu and I dont know how I should install a program on it. I tried using cd the directory where it is and then ./configure it but it is not working!

  • 1
    Are you trying to compile it from the source? May 19, 2013 at 3:13

5 Answers 5


Consider using Damien Cassou's PPA:

To add this PPA:

sudo add-apt-repository ppa:cassou/emacs
sudo apt-get update

For emacs-snapshot:

sudo apt-get install emacs-snapshot-el emacs-snapshot-gtk emacs-snapshot

Or, for emacs24 (i.e. 24.3, stable):

sudo apt-get install emacs24 emacs24-el emacs24-common-non-dfsg


As mentioned in Damien Cassou's PPA, the repository will not be maintained further (currently features Emacs 24.3) and it is recommended to use the Ubuntu Elisp PPA.

Hence, use this to add the PPA:

sudo add-apt-repository ppa:ubuntu-elisp/ppa
sudo apt-get update
sudo apt-get install emacs-snapshot emacs-snapshot-el

Ref: Emacs guide

  • 3
    Note: currently there is an issue with the emacs-snapshot build - they haven't been updated since January since the emacs-snapshot Debian build is currently without a maintainer: see NEWS section of the PPA: launchpad.net/~cassou/+archive/emacs
    – hayd
    Apr 28, 2014 at 17:55

You'll probably be better off using the version of emacs already built, tested, and packaged by Ubuntu rather than building it on your own, unless you need specific features that are only available in 24.3.

In a terminal:

sudo apt-get install emacs
  • 11
    He is specifically mentioning 24.3. He has probably his reasons for that.
    – blueFast
    Feb 27, 2014 at 18:23
  • 2
    We'll probably never know; this asker never logged back on to the site after posting this question back in May. It's also possible that she just thought she needed 24.3 and didn't, and she does say it's her first time using Ubuntu, so she may not have been aware of APT at the time. I was hoping we'd get a response from the asker if the standard, easy way of installing software was presented and didn't meet her needs.
    – Paul
    Feb 28, 2014 at 12:50
  • 10
    @Paul But for future users coming to this question (like me), they are expecting answers that tell them how to install emacs 24.3.
    – user276355
    May 2, 2014 at 19:29
  • Why the hell emacs ask me to install 500MB packages on a fresh ubuntu install? :O
    – Ninsuo
    Jun 17, 2017 at 8:23
  • We came to this thread for emacs 24.3. No, going to latest is not a good idea. For example, Ubuntu 18 comes with emacs 25.2.2, which does not have working scrollbars. May 7, 2018 at 1:42

Building it from source is not bad because you can choose the version that you need and Emacs will work even faster, the trouble is finding and installing dependencies.

Commands to install Emacs 24.5 w/ dependencies:

sudo apt-get update
sudo apt-get install build-essential
sudo apt-get build-dep emacs24
cd ~/Downloads
wget "http://gnu.mirrors.hoobly.com/gnu/emacs/emacs-24.5.tar.gz"
tar xvzf emacs-24.*.tar.gz
cd emacs-24.*
./configure --without-x
sudo make install



I'm using Ubuntu 14 LTS - x64 and following command works for me ;

sudo apt-get install emacs24

For Daily Emacs build installation ;

sudo apt-add-repository ppa:ubuntu-elisp/ppa
sudo apt-get update
sudo apt-get install emacs-snapshot emacs-snapshot-el

Reference : Emacs Guide


The short answer: go back to Ubuntu 16 or earlier.

I just installed Ubuntu 18. The broken scrollbars in emacs 25.2.2 were driving me crazy. The other solutions here didn't work (apt no longer allows unsigned repos). I was able to install emacs 23.4 from the debian packages as follows:


dpkg -i emacs23-common_23.4+1-4+deb7u1_all.deb


dpkg -i emacs23-bin-common_23.4+1-4+deb7u1_amd64.deb


dpkg -i  libgif4_4.1.6-10+deb7u1_amd64.deb


dpkg -i xaw3dg_1.5+E-18.2_amd64.deb


dpkg -i libpng12-0_1.2.49-1+deb7u2_amd64.deb


dpkg -i libtiff4_3.9.6-11+deb7u10_amd64.deb


dpkg -i emacs23-lucid_23.4+1-4+deb7u1_amd64.deb

I'm guessing that this technique would work for emacs 24.3 too.

But you don't want Ubuntu 18. The gnome volumes break everything; after a few reboots, ALL the local volume mounts fail (even /boot/efi, despite the hardware obviously having worked in memfs to get as far as local mount scripts), and you have to mount them manually in the emergency shell every time. Go back to Ubuntu 16, which comes with emacs 24.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.