I formatted my partition of Ubuntu 11.04 and created a new simple volume in Windows. But when I rebooted my laptop, I got an error :no such partition.

I tried nearly all commands suggested, but could not find a way out.

When I type ls it shows:


When I use any of them with ls command individually, I'm returned unknown file system error.

When I tried setting each one as a prefix and root I had problem with insmod.

When I try to use insmod, I'm prompted with error: unknown filesystem. I've tried setting either of these as prefix and then root, but whenever I try to insmod I'm prompted with the same error: unknown filesystem.

  • Insert windows cd/dvd and perform repair. – Web-E May 18 '13 at 10:50

Try to boot the Windows 7 installer and then go to "Repair your computer" enter image description here Then select the 1st option "Startup repair", this should automatically repair your boot partition and run Windows 7, the grub will not appear any more. enter image description here

  • Corrected the spelling for you ;-) – stommestack May 18 '13 at 12:16
  1. create a ubuntu bootable USB,
  2. then launch ubuntu from the USB,
  3. launch ubuntu terminal
  4. write :

sudo apt-get install syslinux

sudo dd if=/usr/lib/syslinux/mbr.bin of=/dev/sda

To create a bootable USB : http://www.ubuntu.com/download/desktop/create-a-usb-stick-on-windows To launch ubuntu from the usb, press F11 or F12 when your computer boot (before windows start). To launch ubuntu terminal Ctrl - Alt + T

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.