2

MATE desktop has recently migrated, as of version 1.6, from using mateconf-editor to gsettings. This breaks traditional solutions for changing MATE's window manager to Compiz.

2

I assume you have already installed Compiz. If not:

sudo apt-get install compiz

gsettings has an equivalent operation to the mateconf-editor key-change operation you had to do to set the window manager to Compiz. Now, to activate Compiz, simply run the following terminal command:

sudo gsettings set org.mate.session.required-components windowmanager compiz

This will change the windowmanager key to compiz in the org.mate.session.required-components schema. Next, I highly recommend installing CompizConfig Settings Manager:

sudo apt-get install compizconfig-settings-manager

With this, you are done. You may either run compiz --replace in the Terminal to start Compiz, or simply reboot your machine. I recommend the latter, as the former may have problems.

  • 3
    no joy. I'm using ubuntu 14.10 mate and when I've restarted the top bar of all windows is missing – Daithí Nov 26 '14 at 8:17
  • Hmm. I don't use Ubuntu anymore, but try running gtk-window-decorator --replace after the system boots up? – mszegedy Dec 19 '14 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.